[Rd] Problem with cut and paste corruption

Ian Thurlbeck i.thurlbeck at strath.ac.uk
Fri Feb 26 12:03:35 CET 2010

Dear All

We have noticed a problem when cut-and-pasting a largish section
(> 4096 bytes ?) of R code from an editor to an R session.

System is Fedora 12 i386 with updates, R-2.9.0 and R-2.10.1 at least.

Problem disappears if you start R with --no-readline !

If happens independently of the editor (tried vim/kate) and the
terminal (tried konsole/gnome-terminal)

Could you please try and reproduce the problem and see if it is
limited to Fedora (Windows XP seems to work fine) ?

I've attached a 5K data file aids.R from the gss package which seems to
trigger the problem.  Just load aids.R into an editor and cut-paste
into a fresh R session and you should see something like:

+ "224", "2
+ "233", "234", "235", "236", "237", "238", "239", "240", "241",
Error: unexpected numeric constant in:
""224", "2

Many thanks

Ian Thurlbeck                http://www.mathstat.strath.ac.uk/
Mathematics and Statistics, University of Strathclyde
Livingstone Tower, 26 Richmond Street, Glasgow, UK,  G1 1XH
Tel: +44 (0)141 548 3667           Fax: +44 (0)141 552 2079

The University of Strathclyde is a charitable body, registered in Scotland, 
number SC015263.

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: aids.R
URL: <https://stat.ethz.ch/pipermail/r-devel/attachments/20100226/dd5abbfa/attachment.pl>

More information about the R-devel mailing list