[Rd] questions as to building R from source under Windows

Peter Ruckdeschel peter.ruckdeschel at web.de
Mon Feb 1 12:08:43 CET 2010

Hi R-devels,

yesterday, on a new computer, in order to check my installation
of "The Windows Toolset", I tried building R from source under
Windows (in fact under Windows 7) --- and in the end succeeded.

Some minor issues though (which I think should not be Windows 7
 issues) which might be of more general interest:

(1) TMPDIR on a different drive:
--- not sure whether this was my fault or you could do anything
about it: On my system, I have a separate drive for temp (i.e. E:),
and had this set in a corresponding TMPDIR environment variable.
During the build process of R, I had difficulties with this,
which were only resolved when I created a tmp folder on the same
drive (i.e. C:) and set environment variable TMPDIR to this new
folder. Is this a known issue /can you reproduce this?
If this is a more general issue, you might want to mention this
in R-admin / or the documentation to Rtools.

(2) TCL:
Although I set the path to TCL in MkRules, line 26 to
   C:\Program Files\R\Tcl   , in step    make rinstaller
I ran into problems, because the build process was assuming
(hard-coded, it seems) the Tcl files to reside in
../../../Tcl (from gnuwin32 folder, which is not the above
set path). Did I miss something? Everything worked fine
after I had copied the /Tcl folder to ../../../Tcl ...

(3) JPEG
Meanwhile the most recent version of jpeg sources is v8,
which is what I downloaded; I succeeded in building R with
this version after a little manual change in bitmap/Makefile .
-> Could you change line 10 in bitmap/Makefile so that it
would branch not only according to whether version was v7 or
not but rather according to whether version was larger or equal
to v7 or not / or set up a v8 alternative?

(4) Did not work for me: build R on D:
            --- a Vista / Windows 7 issue?
In the end I succeeded with my build on drive C: (NTFS formatted)
giving the current user full access privileges to the installation
folders; before, in order to circumvent these privilege issues,
I tried building R on a different drive (D:) which in my case is
formatted as FAT32; somehow I got stuck with this, though;
(my Rtools are on C:). Is this a known issue /can you reproduce this?

Best, Peter

More information about the R-devel mailing list