[Rd] Package names

Hadley Wickham hadley at rice.edu
Thu Sep 3 15:34:15 CEST 2009

>> Currently, writing R extensions states: "The ‘Package’ and ‘Version’
>> fields give the name and the version of the package, respectively. The
>> name should consist of letters, numbers, and the dot character and
>> start with a letter. "
>> Now that _ is no longer an assignment operator, could it be added to
>> this list?
> This would make it trickier to parse PACKAGE_VERSION.tar.gz et al file
> names, and break lots of code based on this naming scheme.

Oh, good point.



More information about the R-devel mailing list