[Rd] Small encoding question

Kurt Hornik Kurt.Hornik at wu-wien.ac.at
Thu Feb 14 20:45:11 CET 2008

>>>>> Vincent Goulet writes:

> Dear developeRs,
> Compilation of the latest version (0.9-5) of my actuar package fails  
> with r-release MacOS_X ix86 on CRAN; see

> 	http://www.R-project.org/nosvn/R.check/r-release-macosx-ix86/actuar-00check.html

> All errors come from accented letters in comments in latin-1 encoded  
> files (except hierarc.R which is in UTF-8, my bad). Encoding is  
> declared as latin-1 in DESCRIPTION.

> The package checks and compiles fine on Windows, Linux and,  
> ironically, my MacOS X main development machine. I realize using non- 
> ASCII characters in source files is not a good idea and I removed  
> them, but I would appreciate any clue as to what went wrong with the  
> compilation on CRAN.

I assume that the MacOS X builds are done in a C locale?



>> sessionInfo()
> R version 2.6.2 (2008-02-08)
> i386-apple-darwin8.10.1

> locale:
> fr_CA.UTF-8/fr_CA.UTF-8/fr_CA.UTF-8/C/fr_CA.UTF-8/fr_CA.UTF-8

> attached base packages:
> [1] stats     utils     datasets  grDevices graphics  methods   base

> other attached packages:
> [1] CarbonEL_0.1-4

> loaded via a namespace (and not attached):
> [1] tools_2.6.2

> Thanks in advance!

> ---
>    Vincent Goulet, Associate Professor
>    École d'actuariat
>    Université Laval, Québec
>    Vincent.Goulet at act.ulaval.ca   http://vgoulet.act.ulaval.ca

> ______________________________________________
> R-devel at r-project.org mailing list
> https://stat.ethz.ch/mailman/listinfo/r-devel

More information about the R-devel mailing list