[Rd] Outdated dependencies and install.packages()

Martin Maechler maechler at stat.math.ethz.ch
Thu Aug 21 19:19:38 CEST 2008

>>>>> "MM" == Martin Maechler <maechler at stat.math.ethz.ch>
>>>>>     on Thu, 21 Aug 2008 09:39:13 +0200 writes:


    MM> Note that --- thanks to Kate Mullen's nice help.request() proposal ---

oops!!   s/Kate Mullen/Heather Turner/

both very fine ladies, both in the program committee of
useR!2008, .... but I do need to apologize here :  


    MM> one of my top "TODOs" for R-devel is
    MM> to finish a generalization of the current
    MM> update.packages()
    MM> function (that I have not quite finished)
    MM> which will allow to only look for updates of specified set of
    MM> packages rather than all packages in a given lib.loc
    MM> {something that should *not* be triggered by a help.request()
    MM> for a user (as ours) who has ~ 2000 R packages installed}.

More information about the R-devel mailing list