[Rd] r won't start: "r: symbol lookup error: r: undefined symbol: (PR#11274)

edd at debian.org edd at debian.org
Fri Apr 25 13:10:08 CEST 2008

On 24 April 2008 at 20:20, jakobstoeger at gmx.de wrote:
| Full_Name: Jakob Stoeger
| Version: 2.7.0
| OS: ubuntu 7.10
| Submission from: (NULL) (
| Hi!
| I hope, it is justified to write this email...
| I'm relatively new to linux, and haven't worked with r, yet, so please pardon
| any things I do not know...
| I tried installing r on my computer, and didn't manage to get the program
| running.
| After having installed littler, typing r into the bash results in following
| message:
| r: symbol lookup error: r: undefined symbol: R_Visible

You need to rebuild littler ('r') against the new version of R ('R'). 

I did that for Debian, looks like Ubuntu could do with it too.  Your R
version was provided by volunteers outside of Ubuntu.

Vincent: In a perfect world, could you rebuild littler and provide it?

Jakob: Barring a new littler you can apt-get, the easiest may be to just
uninstall littler and rebuild it locally so that thew R 2.7.0 is used.
Ping me, or better still, the r-sig-debian list, with questions if you have
any.  You need to subscribe to r-sig-debian before you can post there.

Lastly, if you only want or use R, use R :)  'r' is for scripting and short
command-line uses.


PS  It is the same with RPy.
| I found a bugreport here:
| http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=418686
| I'm not sure, if this has anything to do with it, as it concerns rkward...
| Anyway, this information might come handy:
| my system:
| ubuntu 7.10
| Kernel 2.6.22-14-generic
| GNOME 2.20.1
| installed packages:
| r-base 2.7.0-1gutsy0
| r-base-core 2.7.1gutsy0
| r-cran-cluster 1.11.10-1gutsy0
| r-cran-boot 1.2.32-1gutsy0
| r-cran-cluster 1.11.10-1gutsy0
| r-cran-codetools 0.2-0-1gutsy0
| r-cran-foreign 0.8.24-1gutsy0
| r-cran-kernsmooth 2.22.22-1gutsy0
| r-cran-lattice 0.17-6-1gutsy0
| r-cran-mgcv 1.3-30-1gutsy0
| r-cran-nlme 3.1.88-1gutsy0
| r-cran-rpart 3.1.41-1gutsy0
| r-cran-survival 2.34-1gutsy0
| r-cran-vr 7.2.41-1gutsy0
| rkward 0.4.7a-1ubuntu1
| r-recommended 2.7.0-1gutsy0
| I can't guarantee, that this list is complete, as I don't know (yet), how to
| check for it...
| Not really relevant, but I feel that I should tell you:
| The university at which I study used to use SPSS. Until this term, from which on
| we will officially use r. Yeah!
| So, I hope you can help me getting r working. If I can help by doing anything,
| please tell me how...
| Also, I hope, this is a problem with r and not with my ubuntu, in which case I
| probably wouldn't have contacted you, if I would have known...
| Thank you very much!
| All the best,
| Jakob
| ______________________________________________
| R-devel at r-project.org mailing list
| https://stat.ethz.ch/mailman/listinfo/r-devel

Three out of two people have difficulties with fractions.

More information about the R-devel mailing list