[Rd] Cross-compile errors under R-2.4.0 and R-2.4.1

Daniel Berg daniel at danielberg.no
Fri Jan 19 09:46:09 CET 2007

Dear all,

I already posted a question regarding this to an existing thread:

I apologize for the double posting but I have some further information
that might be illuminating.

I am trying to cross-compile my R-package under ubuntu linux, kernel
2.6.17-10-generic, on an IBM T60.

I am following the suggested steps in

I have tried changing R = R-x.x.x (2.3.1, 2.4.0 and 2.4.1) in

1) For R-2.3.1 everything works fine
2) For R-2.4.0 I receive the following error messages from 'make R':

more undefined references to `__pcre_ucp_findprop' follow
collect2: ld returned 1 exit status
make[4]: *** [R.dll] Error 1
make[3]: *** [../../bin/R.dll] Error 2
make[2]: *** [rbuild] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory

There is already a post that seems to address the same error:

However, I have tried the suggestions there with no further success
and I am awaiting further instructions before pursuing that solution.

3) For R-2.4.1 I receive the following error message from 'make R',
under 'Making package tools':

preparing package tools for lazy loading
Error in makeLazyLoadDB(ns, dbbase) : could not find function "seq_along"
Execution halted

Hope this is illuminating and that the 'bugs', whether it is in R or
in PCRE, can be resolved for the next release, this would be highly
appreciated. Meanwhile, any suggestions as to how I can cross-compile
successfully under R-2.4.1 are most welcome.

Best wishes,
Daniel Berg

More information about the R-devel mailing list