[Rd] troubles installing SJava for R

Erik van Zijst r at erik.prutser.cx
Wed Jan 3 09:49:37 CET 2007

Hello all,

I am using R 2.4.0 and SJava 0.69-0 on linux.

I am not able to install SJava on R. The following errors appear when 

** R
** inst
WARNING: use of install..R is no longer supported
** preparing package for lazy loading
Creating a new generic function for "merge" in "SJava"
** help
 >>> Building/Updating help pages for package 'SJava'
Formats: text html latex example

This error appears when I try to load SJava:

Type 'q()' to quit R.

 > library(SJava)
Error in dyn.load(x, as.logical(local), as.logical(now)) :
unable to load shared library 
/usr/local/lib/R/library/SJava/libs/SJava.so: undefined symbol: R_PPStackTop
Error in library(SJava) : .First.lib failed for 'SJava'
 > q()

Can anyone please help?

We are not a clone.

More information about the R-devel mailing list