[Rd] Bug solved / Re: irr package exits (PR#8839)

marina.saadia at freesbee.fr marina.saadia at freesbee.fr
Sat May 6 14:26:35 CEST 2006

Dear Profs. Ripley & Gamer,

Thanks a lot for your prompt answer and your advice. Indeed, I managed
to track the bug by launching R from the c-shell instead of the Mac GUI.
In that case, after typing
> library(irr)
I obtained the following error message:
> Erreur dans parse(file, n, text, prompt) : syntax error at
> 653: irr.name =3D "R
> Erreur : unable to load R code in package 'irr'

Because Mac, PC and Unix encode end-of-lines differently, this actually
corresponds to line # 1304 in the file "~/Library/R/library/irr/R/irr"
(it should be line # 653 if you work on a PC):
>   rval <- list(method =3D "Mean of bivariate correlations R=FF",
>                subjects =3D ns, raters =3D nr,
>                irr.name =3D "R=FF", value =3D coeff)

The character "=FF" (displayed as a "?" in the c-shell) is clearly not=20=

I thus tried to replace it here by a normal "y", and similarly for=20
"Rho=FF" several
lines lower, and now the package loads without any problem.

I still need to understand how to avoid a conflict between the "icc"=20
defined both in the "irr" and "psy" packages, but this is another=20
story. [Please
feel free to give me any other advice!]

Thanks again; your sincerely,
                                            Marina Saadia Otero

On May 6th, 2006, at 13:44, Prof Brian Ripley wrote:
> Please contact the package maintainer (Cc:ed here).  =46rom the R FAQ:
>   Finally, check carefully whether the bug is with R, or a contributed
>   package.  Bug reports on contributed packages should be sent first =
>   the package maintainer, and only submitted to the R-bugs repository=20=

> by
>   package maintainers, mentioning the package in the subject line.
> and there is similar advice in the R posting guide.
> On Sat, 6 May 2006, marina.saadia at freesbee.fr wrote:
>> Full_Name: Marina Saadia Otero
>> Version: R 2.2.0
>> OS: Mac OS X 10.3.9
>> Submission from: (NULL) (
>> After having installed the "irr" package (from the
>> installation Menu of the Mac interface), the command
>>    library(irr)
>> makes the R application quit. This has been tested from
>> a clean new session, and even from a brand new account.
>> Re-installing the package does not solve the problem.

More information about the R-devel mailing list