[Rd] % symbol in .Rd files?

Martin Maechler maechler at stat.math.ethz.ch
Thu Jul 27 14:48:30 CEST 2006

>>>>> "DoSa" == Dominick Samperi <dsamperi at decisionsynergy.com>
>>>>>     on Thu, 27 Jul 2006 07:52:36 -0400 writes:

    DoSa> Martin Maechler wrote:
    >>>>>>> "DoSa" == Dominick Samperi <dsamperi at decisionsynergy.com>
    >>>>>>> on Mon, 24 Jul 2006 13:07:29 -0400 writes:
    DoSa> Hello, I am encountering problems when there is a
    DoSa> '%' character in package .Rd files. More
    DoSa> precisely, CRAN is having problems with these
    DoSa> characters when running check, whereas I am not
    DoSa> seeing any problems under Linux and Windows.  I
    DoSa> did see these problems, and found that escaping
    DoSa> the %'s fixes the problem in my testing, but
    DoSa> apparently this does not fix the problem when
    DoSa> check is run at CRAN.
    DoSa> I suspect that there are some compatibility
    DoSa> problems between shells, TeX, or perl versions, or
    DoSa> perhaps the check on CRAN goes through more levels
    DoSa> of preprocessing?
    DoSa> I can probably fix this problem by removing all
    DoSa> '%' chars from my .Rd files, but this doesn't seem
    DoSa> like a very natural solution.
    >> definitely not.  Other packages have them as well,
    >> without giving any CRAN hickups
    >> No, you should find and fix the problem.
    DoSa> Any ideas?
    >> We need examples which -- at least for you -- produce the
    >> problem.  You could post a small tar file (mime-types 'application/x-tar'
    >> or 'application/x-compressed-tar' are accepted for R-devel) if
    >> you want.
    >> Martin Maechler, ETH Zurich

    DoSa> An example of the '% problem' is provided by the
    DoSa> RcppExample.Rd file that is part of the RcppTemplate
    DoSa> package (V4.2). There you will find:

    DoSa> # Note that we need to escape the percent sign here...
    DoSa> datestr <- c('2006-6-10', '2006-7-12', '2006-8-10')
    DoSa> datevec <- as.Date(datestr, "\%Y-\%m-\%d") # date vector

which is perfect...
"Writing R Extensions" has always said you must escape them...

    DoSa> Without the escaped '%' signs

you really get invalid examples, not just for example()

    DoSa> I get an obscure error message when
    DoSa> I run:
    >> example(RcppExample)

    DoSa> Here is the error message:
    DoSa> Error in parse(file, n = -1, NULL, "?") : syntax error at
    DoSa> 36:
    DoSa> 37:

Now if I run  'R CMD check RcppTemplate' I see no problem.
In my eyes, everything is ok there.

So where exactly does CRAN (i.e. the CRAN machine that does the
daily checks) have a problem?
Maybe it's really a problem on that machine, than rather with
your *.Rd files ...  :-)

Hmm, actually I now start wondering: Why did we ever start
talking about this at all?  Isn't this something you have to settle
with Kurt, Fritz, or whomever.. ?

Martin Maechler

More information about the R-devel mailing list