[Rd] cannot load rJava in R

Simon Urbanek simon.urbanek at r-project.org
Mon Apr 17 18:41:43 CEST 2006


as per posting guide, please discuss issues with contributed packages  
with the maintainer.

On Apr 15, 2006, at 4:59 PM, Lothar Rubusch wrote:

>  I recently tried to install the rJava package on my notebook  
> (Debian Etch / Kernel 2.6.15 / jdk 1.5.0-5 / R 2.2.1 / rJava ?? the  
> repo one, have a look below). I compiled R myself with "--with- 
> readline=no" and "--enable-R-shlib flags". Now, each time loading  
> the library rJava I encouter the same error. I reinstalled several  
> times (as root), always the same problem:
> JNI_GetCreatedJavaVMs is undefined, isn't it?! I couldn't find  
> anything to that problem so far..
> What went wrong?
> Do I have the recent repository for rJava?
> How can I fix this?

 From the configure output it seems as if you have a fake libjvm.so,  
because there are no library paths and yet it compiles. Please make  
sure that the correct java, javac etc. are on your PATH before you  
compile the package. Also make sure that your Java is properly  
installed (preferably from a Debian package). If that doesn't help,  
please send me your config.log.


More information about the R-devel mailing list