[Rd] trouble building r-devel

Duncan Murdoch murdoch at stats.uwo.ca
Tue Mar 22 01:26:39 CET 2005

On Tue, 22 Mar 2005 10:09:30 +1100, <Mark.Bravington at csiro.au> wrote :

>I haven't been able to build yesterday's R-devel (or, as a test,
>R-devel_2005-03-11) on Windows XP. The error message I'm getting is to
>do with 'arithmetic.c', as shown below.
>Current R-patched seems to build fine, and I've built previous R-devels
>from source fairly often in the past-- though I have no understanding
>whatsoever of what's going on. FWIW the only changes I made to MkRules
>are (i) WINHELP=NO and (ii) TCL_HOME=C:/R/Tcl, which are the same ones I
>always make.
>Any help appreciated!
>C:\R\R-devel\src\gnuwin32> make
><< some OK bits of output, to help show where the problem is>>
>making vfonts.d from vfonts.c
>gcc  -O2 -Wall -pedantic -DLEA_MALLOC -I../include -DHAVE_CONFIG_H
>-DR_DLL_BUILD  -c CConverters.c -o CConverters.o
>gcc  -O2 -Wall -pedantic -DLEA_MALLOC -I../include -DHAVE_CONFIG_H
>-DR_DLL_BUILD  -c CommandLineArgs.c -o CommandLineArg
>gcc  -O2 -Wall -pedantic -DLEA_MALLOC -I../include -DHAVE_CONFIG_H
>-DR_DLL_BUILD  -c Rdynload.c -o Rdynload.o
>gcc  -O2 -Wall -pedantic -DLEA_MALLOC -I../include -DHAVE_CONFIG_H
>-DR_DLL_BUILD  -c Renviron.c -o Renviron.o
>gcc  -O2 -Wall -pedantic -DLEA_MALLOC -I../include -DHAVE_CONFIG_H
>-DR_DLL_BUILD  -c RNG.c -o RNG.o
>gcc  -O2 -Wall -pedantic -DLEA_MALLOC -I../include -DHAVE_CONFIG_H
>-DR_DLL_BUILD  -c apply.c -o apply.o
>gcc  -O2 -Wall -pedantic -DLEA_MALLOC -I../include -DHAVE_CONFIG_H
>-DR_DLL_BUILD  -c arithmetic.c -o arithmetic.o
>arithmetic.c: In function `do_math1':
>arithmetic.c:887: `acosh' undeclared (first use in this function)
>arithmetic.c:887: (Each undeclared identifier is reported only once
>arithmetic.c:887: for each function it appears in.)
>arithmetic.c:888: `asinh' undeclared (first use in this function)
>arithmetic.c:889: `atanh' undeclared (first use in this function)
>make[4]: *** [arithmetic.o] Error 1
>make[3]: *** [rlibs] Error 2
>make[2]: *** [../../bin/R.dll] Error 2
>make[1]: *** [rbuild] Error 2
>make: *** [all] Error 2

My guess would be that you are using bad headers, or perhaps an out of
date compiler.  I just recompiled today's arithmetic.c with no error,

$ gcc --version
gcc.exe (GCC) 3.4.2 (mingw-special)
Copyright (C) 2004 Free Software Foundation, Inc.

Duncan Murdoch

More information about the R-devel mailing list