[Rd] Build Portland Group Compiler

Jennifer Lai lai at lindaspaces.com
Wed Aug 31 23:28:57 CEST 2005

    I built R with Portland Group compiler, but I noticed one thing that 
when I ran configure for the first time on AMD machine, I got the 
following error:

checking whether the C compiler works... configure: error: cannot run C 
compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details.

so I tried to set host=x86_64-unknown-linux-gnu, which seems to work, 
except what puzzles me is that there is warning messages indicating C 
longs are 4 bytes.

% configure --host=x86_64-unknown-linux-gnu
R is now configured for x86_64-unknown-linux-gnu

  Source directory:          .
  Installation directory:    /usr/local/R.pgcc

  C compiler:                /usr/pgi/linux86-64/6.0/bin/pgcc  -g -O2 
  C++ compiler:              /usr/pgi/linux86-64/6.0/bin/pgCC  -g
  Fortran compiler:          /usr/pgi/linux86-64/6.0/bin/pgf77  -O2

  Interfaces supported:      X11
  External libraries:        readline
  Additional capabilities:   PNG, JPEG, MBCS, NLS
  Options enabled:           R profiling

  Recommended packages:      yes

configure: WARNING: assuming C ints are 4 byte on x86_64-unknown-linux-gnu
configure: WARNING: assuming C longs are 4 byte on x86_64-unknown-linux-gnu
configure: WARNING: you cannot build info or html versions of the R manuals

Am I defining a wrong host?


More information about the R-devel mailing list