[Rd] Bundles and 1.9.0 (alpha)

Prof Brian Ripley ripley at stats.ox.ac.uk
Thu Mar 18 09:47:20 MET 2004

I presume this on Windows, but you did not say!

There seems to be a recent problem with Rcmd INSTALL, in that it installs 
under VR, not separately.  But that is the opposite of `merging' the 
packages which are kept separate.  It was not intentional, and has been 

The "VR" (7.1-14) bundle is the wrong version for 1.9.0 (alpha), and it 
should not Rcmd check there.

Please do not post to both R-devel and R-help, and for pre-release
versions please use R-devel.

On Wed, 17 Mar 2004, Jens Henrik Badsberg wrote:

> What is it "Package bundles" and 1.9.0 (alpha) ?
> 'Rcmd check Bundle' aborts with:
> Error: cannot open file '.../Bundle.Rcheck/Package/R/Package' for reading
> In ".../Bundle.Rcheck/" the packages of the bundle are "merged" into a single
> "package".  ('Rcmd INSTALL' does also "merge" the packages of the bundle.)
> I do not in "Writing R Extensions", version 1.9.0, section 1.1.5, see any
> changes (relative 1.8.1) on how bundles should be handled.
> I get the same on abort on the "VR" (7.1-14) bundle.

Brian D. Ripley,                  ripley at stats.ox.ac.uk
Professor of Applied Statistics,  http://www.stats.ox.ac.uk/~ripley/
University of Oxford,             Tel:  +44 1865 272861 (self)
1 South Parks Road,                     +44 1865 272866 (PA)
Oxford OX1 3TG, UK                Fax:  +44 1865 272595

More information about the R-devel mailing list