[Rd] some problems building a package using R CMD CHECK (PR#7118)

roman.pahl at web.de roman.pahl at web.de
Tue Jul 20 13:25:10 CEST 2004


my name is Roman Pahl and recently i tried to build a package under Windows.
I created the skeleton and did alle the documentation stuff.

As i wanted to check it using the 'R CMD CHECK pkgname' command in the Dos-=
console some errors appeared.
I don=B4t know how to handle.
Here are important parts of the log: I marked my questions with a "<-------=

D:\tools\R\rw1090>R CMD CHECK --no-latex GroupSeqPack
* using log directory 'D:/tools/R/rw1090/GroupSeqPack.Rcheck'
* checking for file 'GroupSeqPack/DESCRIPTION' ... OK
* checking if this is a source package ... OK

installing R.css in D:/tools/R/rw1090/GroupSeqPack.Rcheck

---------- Making package GroupSeqPack ------------
  adding build stamp to DESCRIPTION
  installing R files
  installing man source files
  installing indices
There were 18 warnings (use warnings() to see them)                        =
           <------------------------------------------ i tried "warnings()"=
 but that command does not seem to exist
  installing help
 >>> Building/Updating help pages for package 'GroupSeqPack'
     Formats: text html latex example
  alphaByUseFunction                text    html    latex   example
  ........some more functions..........
  useSpendingFunction               text    html    latex   example
 >>> Building/Updating help pages for package 'GroupSeqPack'
     Formats: chm
hhc: not found                                                             =
                            <-------------------------------------------- w=
hat is "hhc" for?
cp: cannot stat `D:/tools/R/rw1090/GroupSeqPack/chm/GroupSeqPack.chm': No s=
uch f <-------------------------  maybe this follows cause of missing hhc
ile or directory
make[1]: *** [chm-GroupSeqPack] Error 1                                    =
              <----------------------------------------  and this ones also=
 following mistakes=20
make: *** [pkg-GroupSeqPack] Error 2                                       =
*** Installation of GroupSeqPack failed ***

* checking package directory ... OK
* checking for portable file names ... OK
* checking DESCRIPTION meta-information ... OK
* checking package dependencies ... OK
* checking index information ... OK
* checking package subdirectories ... OK
* checking R files for syntax errors ... OK
* checking R files for library.dynam ... OK
* checking S3 generic/method consistency ... OK
* checking for replacement functions with final arg not named 'value' ... OK
* checking foreign function calls ... OK
* checking Rd files ... OK
* checking for missing documentation entries ... OK
* checking for code/documentation mismatches ... OK
* checking Rd \usage sections ... OK
* creating GroupSeqPack-Ex.R ... OK
* checking examples ... OK

thanks for your efforts,
Roman Pahl
	[[alternative HTML version deleted]]

More information about the R-devel mailing list