[Rd] unstability when using isoreg() function (PR#6494)

klaster at karlin.mff.cuni.cz klaster at karlin.mff.cuni.cz
Thu Jan 29 08:46:50 MET 2004

> >{
> >library(modreg)
> >N <- 10
> >x <- rnorm(N)
> >print("Original x values:")
> >print(x)
> >for(n in (1:N)){print(y <- isoreg(x[1:n])$yf)}
> >} 
> I get the crash reproducibly in r-devel after I put "set.seed(2)"
> ahead of the sample code above.  (Of course, r-devel doesn't need the
> library(modreg), but that doesn't affect the bug.)  Other seeds and
> the code works without error.

Dear sir,
Thank you for a swift reply.

Yes, but I don't think that seed 2 is the only one producing the crash,
since it occured quite randomly in my testing. For this seed=2 the problem
appeared for isoreg(x[1:3]) and nowhere else, I have tried it just now.
But, after restarting R, I
was able to run isoreg(x[1:4]) through isoreg(x[1:10]), then
isoreg(x[1:3]) and only after calling isoreg(x[1:3]) again R crashed - so
even when I knew there was a problem in isoreg(x[1:3]), it worked (once).

Please let me know if I could do anything else/more to help in tracking
the problem.

Best regards,
Petr Klasterecky

More information about the R-devel mailing list