[Rd] Unmet dependency prevents r-gnome installation in Debian stable (PR#7151)

Dirk Eddelbuettel edd at debian.org
Tue Aug 3 16:08:07 CEST 2004

On Tue, Aug 03, 2004 at 04:01:18PM +0200, nospam at pubhealth.ku.dk wrote:
> Full_Name: Kimmo Uusitalo
> Version: 1.8.0-1
> OS: Debian 3.0 "Woody"
> Submission from: (NULL) (
> r-gnome 1.8.0-1 requires gdk-imlib2 which is not available in Debian 3.0 stable.

That isn't really a bug in R.
> I have the following in /etc/apt/sources.list :
> deb http://cran.r-project.org/bin/linux/debian woody main
> Btw, it would be very nice to have the newest version of R even for Debian
> stable.

You are having a 'round peg in a square hole' problem. Either you take
Debian stable literally, and keep it stable -- so you stick with the ancient
version therein. Or you accept updates, and the easiest may be local

What you found here is a missing Depends in a contributed package that a
volunteer gave back to CRAN. I don't think it is realistic to expect that
all possible system combinations are fulfilled on what is by now an old
system.  Debian stable has its uses (I still run it on my gateway), but if
you care about a current R, I strongly suggest  you rebuild R 1.9.1. 


Those are my principles, and if you don't like them... well, I have others.
                                                -- Groucho Marx

More information about the R-devel mailing list