[Rd] R-1.9.0 beta: vignettes for package grid

Uwe Ligges ligges at statistik.uni-dortmund.de
Fri Apr 9 19:38:42 CEST 2004

Prof Brian Ripley wrote:

> I have no problems on WinXP, so I agree with Peter: check for R_LIBS set
> wrong (which was Stefano's problem last time we saw this) and then for the
> current lattice (0.9-10).
> On 9 Apr 2004, Peter Dalgaard wrote:
>>Uwe Ligges <ligges at statistik.uni-dortmund.de> writes:
>>>Since release of R-1.9.0 is very close, let me mention that there
>>>seems to be a problem when building vignettes for package grid (see
>>>below), e.g. yesterday's R-1.9.0 beta on Windows NT 4.0.
>>>building/updating vignettes for package 'grid' ...
>>>Warning messages:
>>>1: 'viewport.transform' is deprecated.
>>>Use 'current.transform' instead.
>>>See help("Deprecated")
>>>2: 'grid.convertWidth' is deprecated.
>>>Use 'convertWidth' instead.
>>>See help("Deprecated")
>>>3: 'grid.convertHeight' is deprecated.
>>>Use 'convertHeight' instead.
>>>See help("Deprecated")
>>>Error:  chunk 12
>>This looks familiar... Are you sure that you're not picking up an old
>>version of something (lattice, say)? I think that last time we saw it,
>>the reason was either not having run rsync-recommended or having an
>>older version in the library path.

I have unpacked R-1.9.0beta_latest.tar.gz from CRAN master in Vienna 
into a clean directory. Quite probably, I had set R_LIBS before (in 
order to check some problematic packages for R-1.8.x).

Looking closer, there is lattice_0.9-09.tar.gz and lattice_0.9-10.tar.gz 
included in the R-1.9.0beta_latest.tar.gz, but the link lattice.tgz is 
missing. For that reason, lattice was not available at the default 
location and the outdated version in R_LIBS was found.

Therefore, it seems to be a problem with building the beta snapshot.


More information about the R-devel mailing list