[Rd] gtkDevice: configure error from install.packages("gtkDevice") (PR#4575)

WhiteG at dfo-mpo.gc.ca WhiteG at dfo-mpo.gc.ca
Tue Oct 14 13:50:17 MEST 2003

Full_Name: George N. White III
Version: 1.8.0
OS: Irix 6.5
Submission from: (NULL) (

> options(CRAN = "http://cran.us.r-project.org/")
> install.packages("gtkDevice")
* Installing *source* package 'gtkDevice' ...
./configure[1221]: test: argument expected        <<<<<<<<<<<<<<<<
Only versions 1.2 and 2.0 of gtk+ are supported.
** libs
cc -I/usr/local/lib/R/include  -I/usr/freeware/include \
 -I/usr/people/gwhite/include -OPT:IEEE_NaN_inf=ON \
   -mips4 -n32 -O3 -OPT:Olimit_opt=on -c devGTK.c -o devGTK.o
cc-1005 cc: ERROR File = devGTK.c, Line = 33
  The source file "gtk/gtk.h" is unavailable.

  #include <gtk/gtk.h>
1 catastrophic error detected in the compilation of "devGTK.c".
Compilation terminated.
gmake: *** [devGTK.o] Error 2
ERROR: compilation failed for package 'gtkDevice'
** Removing '/usr/local/lib/R/library/gtkDevice'

A workaround is to add the necessary include (-I) directories
and link options to etc/Makeconf.

More information about the R-devel mailing list