[Rd] R 1.4.0 build fails on AIX (PR#1289)

Dan Million lio@hpss1.ccs.ornl.gov
Wed, 30 Jan 2002 14:49:04 -0500 (EST)

On Wed, 30 Jan 2002, Thomas Lumley wrote:

> On Wed, 30 Jan 2002 lio@hpss1.ccs.ornl.gov wrote:
> > Full_Name: Daniel L. Million
> > Version: 1.4.0
> > OS: AIX 5.1 and 4.3.3
> > Submission from: (NULL) (
> >
> >
> > Is there any guidance available on building R on AIX?  Specifically, which C
> > compiler to use?  We have AIX XL Fortran version 7.1.1.  We also have AIX
> > Visual Age C version 5.0.2.  We also have gcc available.
> >
> > I have tried building with "cc" (the default AIX compiler) and "gcc".  During
> > the "make", C compilation in src/library/methods/src completes, and then I
> > see this:
> >
> > mkdir ../../../../library/methods/libs
> > dumping R code in package `methods'
> > make: 1254-059 The signal code from the last command is 11.
> >
> > Apparently the make is running R.bin, which coredumps with a segmentation
> > violation.
> >
> > Do I need to be using a thread-safe compiler (e.g., "cc_r") for this build?
> > Any clues at all as to how to get around this?
> I have successfully built most recent versions of R including 1.4.0 with
> gcc/g77 and with "C for AIX version 5"/"XL Fortran for AIX" on AIX 4.3. I
> haven't been able to mix the GNU and IBM compilers, but I haven't tried
> recently.  Last week I compiled R-patched successfully using gcc/g77. I
> didn't have to do anything special, but AIX has often been source of
> configuration bugs.
> You could try not building the methods package: edit  Makeconf in the top
> R/ directory and remove methods from R_PKGS.
> Also, I think that it's possible to have the methods package build in the
> usual source form rather than as a saved image. I don't know how, but John
> Chambers or Duncan Temple Lang may be able to help.
> These wouldn't actually fix the problem, but would enable you to compile
> everything else.
> I'll try again with the AIX compilers and the new R 1.4.1. It's possible
> that there have been some changes since I last tried, since I usually do
> this shortly before a release.
> 	-thomas

Thanks for the reply.  I tried building without the modules package, and
got past that point.  Now the build fails trying to link tcltk.so.  Seems
the tclConfig.sh on my host refers to a file that does not exist

I'll freely admit to being clueless about most of this.  I don't know
anything about R; I'm just a sysadmin trying to build/install it for a
user who needs it.


r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch