[Rd] solved(?) (was RE: MKL seems to beat ATLAS, but some problems...)

Liaw, Andy andy_liaw@merck.com
Thu, 17 Jan 2002 15:17:44 -0500

Prof. Ripley,
> > Sorry, but seems like I need a bit more spoon-feeding:
> > I did the dyn.load, and got:
> >         unable to load shared library
> > "/home/andy/R-patched-mkl/modules/lapack.so":
> >   /home/andy/R-patched-mkl/modules/lapack.so: undefined 
> symbol: lsame_
> Right, that's it.  LSAME is a BLAS routine, and your BLAS doesn't have
> it.  There is a version in src/appl/blas.f, but you don't seem to
> have a complete BLAS to link against.

Strangely, I found lsame in libmkl_lapack.a (which I guess is the Lapack
part of MKL).  I did a real ugly hack: I inserted the link flags to this
library in RHOME/src/modules/lapack/Makefile, where lapack.so is built.
That seems to have solved the problem.  The resulting build passes make
check w/o any error.

> If you really have a complete LAPACK3 (which I would not bet on)
> you can try building in src/modules/lapack omitting double.f and
> complex.f: you will need to rename a few entry points in Lapack.h
> as they have already been changed to avoid conflicts with sunperf
> (I think).  See also the comments in the README there.

I think I'll just follow the advise in that README file, at least for now...

Thanks very much for your help!


r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch