[Rd] R-1.2.3: a small suggestion (PR#961)

A. J. Rossini rossini@u.washington.edu
Thu, 31 May 2001 15:13:04 -0700 (PDT)

On 1 Jun 2001, Peter Dalgaard BSA wrote:

> rossini@blindglobe.net (A.J. Rossini) writes:
> > >>>>> "r" == ripley  <ripley@stats.ox.ac.uk> writes:
> >
> >     r> There is a serious problem with that. All the user-installed
> >     r> packages in /usr/local/lib/R-1.2.3/library disappear from view
> >     r> on upgrade.  They would need to be migrated.
> >
> > One thought would be to emulate XEmacs in this regard -- lisp packages
> > are in equivalent of /usr/local/lib/R, while version-specific code is
> > in the equivalent of /usr/local/lib/R-version.
> But R packages are not always binary compatible between releases. You
> can't win. I think most of the development team just use the "run from
> builddir" option.
> Could we perhaps add a configure switch to install in R-$VERSION ?
> --versioned-install or something like that. Kurt?

Alternatively, let people do it both ways, and suffer (i.e. install
libraries in the versioned location, as well as in the "generic"

(I'm feeling really grumpy this year).


r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch