[Rd] Depends: R (>= x.y.z)

Thomas Lumley tlumley@u.washington.edu
Mon, 11 Jun 2001 09:55:57 -0700 (PDT)

On Mon, 11 Jun 2001, Paul Gilbert wrote:

> KH> You can do
> KH>        Depends: R (<= 1.2.3)
> Yes, but the problem is that building a package now, say for 1.3.0,
> who  knows whether one should specify
> Depends: R (< 2.0)
> or
> Depends: R (< 3.0)
> And when those versions come along the maintainer may not be around to
> make the change to the Depends line. (An if they were they would
> probably update the package instead.)

Yes, a < depends should almost never be correct. However, changing it to a
prefix doesn't help with this.  About the only situation when this would
apply is if we decide to break source compatibility  (eg to put threads
in). Here the CRAN maintainers will know what the dependency is, but it
may not be fixed immediately.

We don't want the depends to mean "was only tested with". It should mean
"will not work without". In most cases only the package maintainer can
distinguish between a bug (which may be exposed more clearly by a new
version of R)  and a valid dependency.


r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch