[Rd] problem loading packages (PR#559)

rnassar@duke.edu rnassar@duke.edu
Fri, 2 Jun 2000 02:08:40 +0200 (MET DST)

Dear R team,

I had a strange problem that appeared suddenly, and which I'd like to
to mention in case it is of interest (although I suspect that I
may have unwittingly done something dumb: if so please accept my apology)

> library(ctest)      ## or any package other than "oz" that I tried
Error in as.character(table) : Object ".Dyn.libs" not found
> traceback()
[1] "as.character(table)"                "match(chname, 
[3] "library.dynam(\"ctest\", pkg, lib)" "firstlib(which.lib.loc, 
[5] "library(ctest)"                    

I traced the problem to my .RData file, and specifically to ".AutoloadEnv"

> ls(all.names=TRUE)
 [1] ".AutoloadEnv"        ".GlobalEnv"          ".Library"           
 [4] ".Machine"            ".Platform"           ".PostScript.Options"
 [7] ".Provided"           ".Random.seed"        ".Traceback"         
[10] ".lib.loc"           

I removed the above, one at a time, and tried loading a library.  It
worked after I removed  ".AutoloadEnv".  I confirmed it by checking
that R works normally if I only remove ".AutoloadEnv".  I don't know
what could have caused the problem in the first place.  The contents
of ".AutoloadEnv" are shown below: 

> .AutoloadEnv
<environment: 0x40691ddc>
[1] "Autoloads"

> rm(".AutoloadEnv")
> library(gee)
> library(nlme)
Loading required package: nls 

Thank you very much.

Rashid Nassar

--please do not edit the information below--

 platform = i586-unknown-linux
 arch = i586
 os = linux
 system = i586, linux
 status = 
 major = 1
 minor = 0.1
 year = 2000
 month = April
 day = 14
 language = R

Search Path:
 .GlobalEnv, package:ctest, Autoloads, package:base

r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch