[Rd] R-devel Aug-09 1.2.0 build on hpux10.20

Kurt Hornik Kurt.Hornik@ci.tuwien.ac.at
Sun, 13 Aug 2000 09:00:32 +0200

>>>>> Prof Brian D Ripley writes:

> On Fri, 11 Aug 2000, U-E59264-Osman F Buyukisik wrote:
>> Prof Brian D Ripley writes:
>> > > It seems like d1mach and a few others are not in any of the blas libs
>> > > I have :-( Also my hp supplied blas libs are .a not shared. Can't load 
>> > > them when building modreg.sl
>> > 
>> > Why not?  That is what is supposed to happen when $(BLAS_LIBS) is
>> > included on the load line, shared or not.
>> I get an error about non position independent code being in the
>> lib. Tells me to recompile with +z option !!  
>> This is a shortcoming of hp's linker I think. 

> Ah, yes, and I guess you have the same problem with Tcl/Tk, then.

> I think that's it. Glad we got there.

>> > 
>> > Try using --without-blas or --with-blas=no.  If that works,
>> > try --with-blas=blas (or whatever).  If it does not work,
>> > the problem is not blas-related.
>> > 
>> OK, --without-blas worked. Everything loads now. Thanks.
>> I guess I still don't understand the config options :-(
>> --with-blas=/opt/fortran/lib/pa2.0/libblas.a

> --with-blas=blas?  That's all that is likely to work. Set
> LD_LIBRARY_PATH (or HP's equivalent) accordingly.

>> still grabs -latlas
>> My shell is bash.
>> I edited Makeconf and etc/Makeconf and did a make. Worked :-)

The (fast) BLAS configure code is taken from Octave.  It interprets an
option like


as a `suggestion' to be tried first.  If this fails, it goes on to check
for other blas libs it knows about.  Can you check your config.log to
see whether your --with-blas=/opt/fortran/lib/pa2.0/libblas.a test

The way to turn off all fast BLAS checking is


r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch