[Rd] R-devel Aug-09 1.2.0 build on hpux10.20

U-E59264-Osman F Buyukisik osman.buyukisik@ae.ge.com
Fri, 11 Aug 2000 15:05:39 -0400 (EDT)

Prof Brian D Ripley writes:
 > > It seems like d1mach and a few others are not in any of the blas libs
 > > I have :-( Also my hp supplied blas libs are .a not shared. Can't load 
 > > them when building modreg.sl
 > Why not?  That is what is supposed to happen when $(BLAS_LIBS) is
 > included on the load line, shared or not.

I get an error about non position independent code being in the
lib. Tells me to recompile with +z option !!  
This is a shortcoming of hp's linker I think. 

 > Try using --without-blas or --with-blas=no.  If that works,
 > try --with-blas=blas (or whatever).  If it does not work,
 > the problem is not blas-related.

OK, --without-blas worked. Everything loads now. Thanks.

I guess I still don't understand the config options :-(
still grabs -latlas
My shell is bash.
I edited Makeconf and etc/Makeconf and did a make. Worked :-)
Thanks again, 

r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch