install.package errors

Paul Gilbert
Wed, 22 Dec 1999 15:01:32 -0500

Paul Johnson

I'm copying this to R-devel because I think the warning messages might
be improved a bit (and I'm not sure what the problem is but there may
also be a bug). I think the install.packages() and update.packages()
mechanism is very exciting. It speeds and simplifies updates, which is
very important when things are changing as rapidly as they are now
changing, but it still has a few rough edges.

> I'm a complete R-package novice.
>What am I doing wrong:


>sh: wget: command not found
>Error: Object "x" not found
>In addition: Warning message:
>argument `lib' is missing: using /usr/lib/R/library in:
>install.packages(c("syskern", "tframe", "dse"), contriburl =

First of all, you might try install.packages(c("tseries", "VR")) or some
other packages directly from CRAN to see if you get a similar error.
Installing from my server by setting contriburl is still somewhat
experimental (and perhaps unorthodox).  Syskern and tframe are standard
packages, but dse is a bundle of two packages together. This is
something new in R 0.90.1 which I don't think was supported in 0.90.0.

Also, I think install.packages is only supported in Unix so far, and it
depends on another utility which you may have to install. My Linux
distribution had wget installed, but I had to install it on my Solaris
system. (I got it from There can be
additional problems with firewalls and proxy servers. If you do not want
to install this way yet, you can download the three tar.gz files from by
web site and install them in the standard way, but I think you will be
impressed with install.packages() when it works.

Install.packages uses download.file() which by default tries to
determine if you have cp, wget, or lynx for getting a file from a server
on the Internet. The message "sh: wget: command not found" suggests you
do not have wget and, if I understand things correctly, download.files
has already not found cp and will next try lynx. If it does not find
lynx it returns the message "No download method found", and since you
did not get that message I think lynx must have been found. I get the
"argument 'lib' is missing ..." warning, but it does not seem to be a
problem. It may be a problem if you do not have write permission in the
directory where R is installed.

I can't tell what program cannot find the object x. If you can generate
the error again and then do traceback() it would be helpful. I tried to
generate the error this morning running Linux from home, and have
generated some other problems you may watch out for, but not that one.
On the first attempted my Internet connection stalled on dse, but the
first two packages installed ok. On my second attempt everything worked
ok, except I was running on a machine which did not have a fortran
compiler. The warning about this was very hard to see with all the other
output that is generated. (R-devel: I think --quiet to wget would be a
better default and it would be nice if the output from R INSTALL could
be surpressed except for error and warning messages. Possibly this can
be accomplished simply by redirecting the output to a scatch file and
grepping for warnings and errors.) On the third attempt, as with my
attempts yesterday, everything worked ok.

I will be out of the office for the next two weeks. I'm sorry to leave
you without better suggestions about the problem. If there are not other
suggestions from R-devel you may want to try the more traditional
install (downloading the files gunzip and un-tar, then R INSTALL ...)

Merry Christmas and Happy New Year.
Paul Gilbert

r-devel mailing list -- Read
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: