R on AIX

Kurt Hornik Kurt.Hornik@ci.tuwien.ac.at
Thu, 22 Apr 1999 15:20:19 +0200 (CEST)

>>>>> Martin Maechler writes:

>>>>> "FrL" == Friedrich Leisch <Friedrich.Leisch@ci.tuwien.ac.at> writes:
FrL> I tried to build R on AIX and after 2 minor bugfixes everything
FrL> seems to work fine except for dynamic loading of code.

FrL> In a previous mail I found that Fabrizio Moro succeeded using

FrL> SHLIBLDFLAGS="-bM:S1L -bnoentry -bnogc -berok -lc -lm -lodm -lcfg"

FrL> which compiles fine for me, I get also no error messages upon
FrL> dynloading, but no symbols are available afterwards,
FrL> i.e. is.loaded fails (I tried also with trailing underscores
FrL> etc.).

> Yes.  Unfortunately, Fabrizio (nor me) followed up on that mail telling you
> that we (Fabrizio and me) ended up with the exact same symptomps as you
> have.

> I gave up at that time; Fabrizio continues to use S-plus on AIX
> (and R on Linux, to some extentes at least)...
> ... yes a sad story,  but I think we both ended up with the impression that
> AIX is half broken environment anyway 
>  --- at least if you want to compile software that has no problems at all
>      on other architectures...

FrL> Has anybody some experience which flags to use?

FrL> I use an rs6000-ibm-aix4.2.1.0 and the native cc, f77 and ld (gcc
FrL> compiles but produces incorrect code, i.e., some computations are
FrL> wrong).

FrL> Make check succeeds until eda :-)

> exactly. The first time, dyn.load is needed....

It might help to look into other software for which dynloading works
under AIX.  Three potential examples come to mind:


Anyone willing to have a look?

r-devel mailing list -- Read http://www.ci.tuwien.ac.at/~hornik/R/R-FAQ.html
Send "info", "help", or "[un]subscribe"
(in the "body", not the subject !)  To: r-devel-request@stat.math.ethz.ch