[ESS] Issue with polymode installed from ELPA

Sparapani, Rodney r@p@r@p@ @end|ng |rom mcw@edu
Tue Sep 10 20:55:09 CEST 2019

Hi Michael:

Oh, sorry.  The errors are something like "file polymode not found".  So
not necessarily related to the load order.  The load errors come from 
the brute force method of manually loading the files in the wrong
order (which I resolved).  So, I've just tested it, but I didn't get any crashes.
I will keep an eye out for crashes and let you know if I see anything.
I have tried Aquamacs, but I never liked it much.  They have tried too
hard to make it Mac-like.  I like Emacs to be like Emacs regardless of
platform.  The exception is that I love the Apple Command keys
which allow Apple HIG Cut/Copy/Paste.  Fortunately, both Aquamacs 
and Vincent's Emacs support these.  But, I digress.



On 9/10/19, 1:45 PM, "Braun, Michael" <braunm using mail.smu.edu> wrote:

    ATTENTION: This email originated from a sender outside of MCW. Use caution when clicking on links or opening attachments.
    I use Aquamacs 3.5, based on emacs 25.3, ESS 18.10.3snapshot from MELPA, OSX 10.14.16, and the following works for me.
    (add-to-list 'load-path "~/Library/Preferences/Aquamacs Emacs/Packages/lisp/")
    (require 'ess-site)
    (load "ess-autoloads")  ;; need to register Rnw files
    (require ‘polymode) ;; version 2.0 now
    (require 'poly-markdown)
    (require 'poly-noweb)
    (require 'poly-R)  ;;
    I, too, found the order mattered, but I think it’s because poly-R depends on poly-noweb and poly-markdown, which depend on polymode.
    But I am more interested in the errors you are getting.  After upgrading to poly-R-2.0, I found that clicking on the menubar while an R buffer was open was crashing Aquamacs (and replicated on Emacs 26.3).  I’ll start another thread once I’ve narrowed down the source of the problem some more, but I am curious if this is related.
    > On Sep 10, 2019, at 5:02 AM, ess-help-request using r-project.org wrote:
    > Send ESS-help mailing list submissions to
    >       ess-help using r-project.org
    > To subscribe or unsubscribe via the World Wide Web, visit
    >       https://urldefense.proofpoint.com/v2/url?u=https-3A__stat.ethz.ch_mailman_listinfo_ess-2Dhelp&d=DwIGaQ&c=aFamLAsxMIDYjNglYHTMV0iqFn3z4pVFYPQkjgspw4Y&r=2M6XAlqJdq-Ryc3EDyECCw&m=dYKcJQQdnqPAwZLnaafUicu64ZbOPCYOgVCpnYPWoM4&s=8zTx545jL-kB-X7IutugeLyw9FbVPFJo2sUNNjohreU&e=
    > or, via email, send a message with subject or body 'help' to
    >       ess-help-request using r-project.org
    > You can reach the person managing the list at
    >       ess-help-owner using r-project.org
    > When replying, please edit your Subject line so it is more specific
    > than "Re: Contents of ESS-help digest..."
    > Today's Topics:
    >   1.  Issue with polymode installed from ELPA (Sparapani, Rodney)
    > ----------------------------------------------------------------------
    > Message: 1
    > Date: Tue, 10 Sep 2019 02:25:56 +0000
    > From: "Sparapani, Rodney" <rsparapa using mcw.edu>
    > To: ess-help <ess-help using r-project.org>
    > Subject: [ESS] Issue with polymode installed from ELPA
    > Message-ID: <1A2467F8-5B2A-486A-ACF9-23E427BA8D79 using mcw.edu>
    > Content-Type: text/plain; charset="utf-8"
    > Hi Gang:
    > I am stumped.  I tried to install polymode from ELPA into Vincent Goulet's
    > distro of Emacs and ESS (it no longer contains polymode sadly).
    > macOS 10.14.4 Mojave, Emacs version 26.2 and ESS version 18.10.2
    > The ELPA install seemed to go well.  My load-path starts with
    > ("/Users/rsparapa/.emacs.d/elpa/poly-R-0.2"
    > "/Users/rsparapa/.emacs.d/elpa/poly-markdown-0.2"
    > "/Users/rsparapa/.emacs.d/elpa/markdown-mode-2.3"
    > "/Users/rsparapa/.emacs.d/elpa/poly-noweb-0.2"
    > "/Users/rsparapa/.emacs.d/elpa/polymode-0.2" ...
    > So, everything looks good.  But, I get errors when I put simple requires in
    > .emacs like (require 'polymode)
    > So, I hard-coded all of the paths, but this gets hairy since now I have to
    > hard-code all of the dependencies too ...
    > (require 'polymode-classes "~/.emacs.d/elpa/polymode-0.2/polymode-classes.el")
    > (require 'polymode-core "~/.emacs.d/elpa/polymode-0.2/polymode-core.el")
    > (require 'polymode-compat "~/.emacs.d/elpa/polymode-0.2/polymode-compat.el")
    > (require 'polymode-methods "~/.emacs.d/elpa/polymode-0.2/polymode-methods.el")
    > (require 'polymode-export "~/.emacs.d/elpa/polymode-0.2/polymode-export.el")
    > (require 'polymode-weave "~/.emacs.d/elpa/polymode-0.2/polymode-weave.el")
    > (require 'polymode-base "~/.emacs.d/elpa/polymode-0.2/polymode-base.el")
    > (require 'poly-lock "~/.emacs.d/elpa/polymode-0.2/poly-lock.el")
    > (require 'polymode "~/.emacs.d/elpa/polymode-0.2/polymode.el")
    > (require 'poly-noweb "~/.emacs.d/elpa/poly-noweb-0.2/poly-noweb.el")
    > (require 'poly-markdown "~/.emacs.d/elpa/poly-markdown-0.2/poly-markdown.el")
    > (require 'poly-R "~/.emacs.d/elpa/poly-R-0.2/poly-R.el")
    > Getting the order of the dependencies right was a pain as well.  However,
    > brute force fixed it!  But, I don't want to go through this ever again for
    > obvious reasons.  It took me over an hour for what is supposed to be a 5 or
    > 10 minute install.  Does anyone have an idea of WTF is going wrong here?
    > Thanks,
    > Rodney
    > ------------------------------
    > Subject: Digest Footer
    > _______________________________________________
    > ESS-help mailing list  DIGESTED
    > ESS-help using r-project.org
    > https://urldefense.proofpoint.com/v2/url?u=https-3A__stat.ethz.ch_mailman_listinfo_ess-2Dhelp&d=DwIGaQ&c=aFamLAsxMIDYjNglYHTMV0iqFn3z4pVFYPQkjgspw4Y&r=2M6XAlqJdq-Ryc3EDyECCw&m=dYKcJQQdnqPAwZLnaafUicu64ZbOPCYOgVCpnYPWoM4&s=8zTx545jL-kB-X7IutugeLyw9FbVPFJo2sUNNjohreU&e=
    > ------------------------------
    > End of ESS-help Digest, Vol 199, Issue 3
    > ****************************************
    Michael Braun, Ph.D.
    Associate Professor of Marketing, and
      Corrigan Research Professor
    Cox School of Business
    Southern Methodist University
    Dallas, TX 75275
    braunm using smu.edu

More information about the ESS-help mailing list