[ESS] Failing to load r-autoyas

Fernando Mayer fernandomayer at gmail.com
Sat Mar 24 00:28:21 CET 2012


I was trying to use r-autoyas [1], but was not very succesfull. I've
downloaded r-autoyas.el from here [2] and put it in my ~/emacs.d/ . In
my .emacs I have

(add-to-list 'load-path "~/.emacs.d/")
(require 'ess-site)
(require 'r-autoyas)

but when I open emacs/ess and R and try something like


nothing happens, not even a warning or error message from buffer. In
the *Messages* buffer I also don't see any call to r-autoyas.

Some other things I've tried (not cumulatively):

1) Put r-autoyas.el in /etc/emacs/site-start.d/ (since I'm sure this
is in the load-path)
2) Put this in .emacs:

(yas/load-directory "/usr/share/emacs/site-lisp/yasnippet/snippets")

3) I've yanked all the content of r-autoyas.el into my .emacs
4) M-x load-file <r-autoyas.el>

In neither of them it worked.

This may be something basic I'm missing since I'm not a Lisp expert,
but I can't figure out what is going wrong here.

I'm using Ubuntu 11.10 with:

R 2.14.2 (compiled from source)
ESS 5.14-1oneiric0 (installed via apt from a CRAN mirror)
Emacs 23.3.1 (via apt from Ubuntu repositories)
yasnippet 0.6.1c-1 (via apt from Ubuntu)
r-autoyas.el 0.18 (via [2])

[1] http://www.emacswiki.org/emacs/ESSr-autoyas
[2] http://www.svenhartenstein.de/uploads/r-autoyas.el

Thanks in advance for any suggestion,

Fernando Mayer
Universidade Federal de Santa Catarina - UFSC
Departamento de Ecologia e Zoologia - ECZ/CCB
URL: http://sites.google.com/site/fernandomayer
e-mail: fernandomayer [@] gmail.com

More information about the ESS-help mailing list