[ESS] help with error in ess-site.el

georgina.bermann at novartis.com georgina.bermann at novartis.com
Sat Apr 30 02:26:18 CEST 2011

I have posted the same error earlier, and I would like a suggestion on how 
to fix the ess-site.el file [ess-5.13].  The error appears in Section 2.1
Starts with the ess-sqpe-versions etc in the section pasted below: a 
compilation indicates that the symbol's definition is void ess-uniq-list

(let ((R-newest-list '("R-newest"))
      (ess-s-versions-created (if ess-microsoft-p
ess-SHOME-versions)               ;; 32-bit
ess-SHOME-versions-64 "-64-bit")) ;; 64-bit
                                (ess-s-versions-create)))) ;; use 
  (if ess-microsoft-p
      (setq ess-rterm-version-paths ;; (ess-find-rterm))
              (if (getenv "ProgramW6432")
                  (let ((P-1 (getenv "ProgramFiles(x86)"))
                        (P-2 (getenv "ProgramW6432")))
                     ;; always 32 on 64 bit OS, nil on 32 bit OS
                     (ess-find-rterm (concat P-1 "/R/") "bin/Rterm.exe")
                     (ess-find-rterm (concat P-1 "/R/") 
                     ;; keep this both for symmetry and because it can 
                     (ess-find-rterm (concat P-1 "/R/") 

                     ;; always 64 on 64 bit OS, nil on 32 bit OS
                     (ess-find-rterm (concat P-2 "/R/") "bin/Rterm.exe")
                     (ess-find-rterm (concat P-2 "/R/") 
                     (ess-find-rterm (concat P-2 "/R/") 
                (let ((PF (getenv "ProgramFiles")))
                   ;; always 32 on 32 bit OS, depends on 32 or 64 process 
on 64 bit OS
                   (ess-find-rterm (concat PF "/R/") "bin/Rterm.exe")
                   (ess-find-rterm (concat PF "/R/") "bin/i386/Rterm.exe")
                   (ess-find-rterm (concat PF "/R/") "bin/x64/Rterm.exe")

If I comment out the region, and try to edit a noweb file (Rnw) it will 
not load it. I have tried with a number of other earlier versions, but 
always seem to encounter problems with the microsoft version names and 
definitions. I use XEmacs 21.4 (patch 8) under windows nt. 5.13 works 
perfectly with XEmacs 21.4 (another patch number) under Linux -but in this 
environment it refuses to work. 
Earlier I could bypass these problems but commenting out regions with 
error messages, but now I cannot fix the problem without messing up 
dependencies that are needed to get the noweb-mode working. I run a lisp 
evaluation of almost all files, and the only complaint I found (besides 
ess-site.el) was in the ess.el file (ess-write-to-dribble-buffer got 
I have an old version of ess (2002) installed with this ancient XEmacs 
version we run, but it fails just with these files apparently it enters an 
endless loop (I am attaching acopy of the *ESS* buffer).  Either fixing 
this version to get it to edit as it should, or fix the ess-site.el in 
5.13 would be a solution.
I would very much appreciate some help as I am heavily dependent on ESS 
editing help with Rnoweb files.

Best regards, Mit freundlichen Grüssen, Meilleures salutations, 
Georgina Bermann PhD
Senior Expert Statistician
Novartis Pharma AG
CH-4056 Basel
Phone: +41 61 3246032
Fax: +41 61 3248611
Email : georgina.bermann at novartis.com

More information about the ESS-help mailing list