[ESS] SOLVED: Syntax highlighting in R not working

Tyler Smith tyler.smith at eku.edu
Fri Jan 29 15:39:08 CET 2010

Rainer M Krug <r.m.krug at gmail.com> writes:

> On Fri, Jan 29, 2010 at 3:37 AM, Tyler Smith <tyler.smith at eku.edu> wrote:
>> Rainer M Krug <r.m.krug at gmail.com> writes:
>> > I am using emacs 23 and ESS under Ubuntu Karmic, both installed from the
>> > default repositories.
>> >
>> > But I don't seem to have any syntax highlighting (see attached
>> screenshot).
>> > As far as I remember, I had it earlier. I tried to reinstall emacs23 and
>> ESS
>> > and removed my ~/.emacs file, but sno effec, as you can see in the
>> > screenshot.
>> >
>> Are you sure your .emacs file is gone? The screen shot shows white text
>> on a black background, which is not the default color scheme. Unless you
>> opened emacs with emacs -Q, manually changed the color scheme, and then
>> opened R, there is a config file being loaded somewhere.
> I know - that is what irritated me as well.
> I figured out what the problem was - it is the package emacs-extra. AS soom
> as I install this package, the syntax highlighting is gone.

Ah. I'm running Debian, and stopped using the pre-packaged Emacs a few
years ago, due to similar frustrations with 'helpful' configurations
provided by the package maintainers.



More information about the ESS-help mailing list