[ESS] ESS and Windows 7

Paul Johnson pauljohn32 at gmail.com
Sat Jan 23 01:00:18 CET 2010

I made Emacs work on Windows 7 today.  If you install R and Vincent
Goulet's enhanced version of Emacs with all of the default settings
(don't fiddle with the path), then Emacs with ESS will "just work".
x-R does start Rterm.exe.

However, if you put R somewhere else, then you have to make the
changes you described  in your note. But you have to do them
CORRECTLY. See below.

On Sat, Dec 26, 2009 at 4:42 PM, Edith Hodgen <edith.hodgen at gmail.com> wrote:
> Hi
> I have a new computer operating under Windows 7 and am again facing the
> trials of getting Emacs, ESS, R and LateX to work. This time the problem
> seems to be around ESS and R (the rest, including spell checking, seems
> fine, and R works on its own, but not in ess/macs).
> I've been following the instructions on the sites aimed at the less
> competent, and have put ess here:
>  c:/devel/emacs/site-lisp/ess:
> and R here:
> c:/devel/R/R-2.10.1/bin:
> Running addpm.exe also didn't seem to work quite as I remembered it, and I
> had to go and make a short-cut to runemacs.exe. However, Emacs works, I get
> a LaTeX environment, and I can check spelling.
> I've used the pattern of my previous .emacs files, with modifications
> suggested for the newer releases.
> In particular, I've tried both versions of the first of the following
> sections (unsuccessfully)
> ==================================
> ;; ESS
> ;;(load "C:/devel/emacs/site-lisp/ess/lisp/ess-site")
> (require 'ess-site)
> ;; R
> (setq inferior-R-program-name "C:/devel/R/R-2.10.1/bin/Rterm.exe")

Follow the example in the ess-site.el file, you NEED double slashes,

After fixing that, then DELETE ess-site.elc.  That's the byte compiled
version that Emacs will use first, it will ignore your new el file if
you leave the elc file.

I've found some little malfunctions with Emacs and ESS, but I can
assure you it works just as well with Windows 7 as it did with Vista


> (add-hook 'LaTeX-mode-hook 'turn-on-reftex)
> ====================================
> I tried editing the ess-site.el file (I remember having to do that in
> earlier versions), and leaving it as it was (equally unsuccessful).
> I then tried deleting the whole lot and downloading the GNU Emacs and ESS -
> All-in-one installation file for MS Windows, by Vincent Goulet, but for some
> reason, after downloading for several minutes, it went all shy and refused
> to save the file (more than once - I did try again). I put a copy of his
> site-start.el into the emacs/site-lisp directory and that also didn't
> perform magic.
> My PATH is:
> C:\devel\MiKTeX
> 2.8\miktex\bin;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\C:\tools\bin;C:\devel\emacs\bin;C:\devel\texmf\miktex\bin;C:\devel\ghostgum\ghostview\gsview\;c:\usr\local\bin;C:\devel\ghostgum\gs\gs8.51\lib;C:\devel\ghostgum\gs\gs8.51\bin;C:\devel\MinGW\bin;c:\devel\Aspell\bin;C:\devel\R\R-2.10.1\bin
> I've double, triple, and quadruple-checked spelling everywhere (which means
> I've probably overlooked something), and have searched on the Internet for
> clues. I saw one other query about Windows 7, but that resolved itself, so
> my guess is that it *should* work.
> In Emacs, M-x R causes the message: [No match]
> and there is no *ESS* buffer.
> Any assistance will be extremely gratefully received.
> Edith
>        [[alternative HTML version deleted]]
> ______________________________________________
> ESS-help at stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/ess-help

Paul E. Johnson
Professor, Political Science
1541 Lilac Lane, Room 504
University of Kansas

More information about the ESS-help mailing list