[ESS] Cant kill R -process

Paul Leo p.leo at uq.edu.au
Fri Feb 6 08:19:18 CET 2009

Thank-you for the quick response ... C-g worked a treat.  
My apologies if this is a frequent newbie question , I had only gone
back a few months in the email archives before I opted for immediate

Thanks again

-----Original Message-----
From: Kasper Daniel Hansen [mailto:khansen at stat.berkeley.edu] 
Sent: Friday, February 06, 2009 11:27 AM
To: Paul Leo
Cc: ess-help at stat.math.ethz.ch
Subject: Re: [ESS] Cant kill R -process

This has been answered multiple times on the list.

C-g gives you command back to emacs, after which C-c C-g essentially  
stops it (like C-c in a shell).


On Feb 5, 2009, at 17:12 , Paul Leo wrote:

> Hi
> I've been giving ESS and emacs a try for a few weeks and found it  
> quite
> nice but I have ONE problem which is killing my progress.
> I can't seem to terminate a R-command which is taking too long . I am
> using ubuntu intrepid 64bit and the intrepid ports of ESS from CRAN
> 5.3.10-Intrepid and Emacs 22.2.1. When I run a command which takes a
> long time the top line of command on the R buffer window ...
> File ......  iESS Complete In/Out Signals Help
> are non-responsive .Actually this line on the R edit session is also
> unresponsive and Emacs C- or M- also don't work.
> If there a way to stop a process that I have missed in the manual? ...
> other that terminating the process id from a terminal!
> Thanks
> Paul
> ______________________________________________
> ESS-help at stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/ess-help

More information about the ESS-help mailing list