[ESS] Command completion (redux)

James W. MacDonald jmacdon at med.umich.edu
Tue Jun 10 16:41:00 CEST 2008

Until recently I have been able to get command completion to work using 
<TAB>, in an inferior R buffer for both function names, as well as paths 
(by adding utils::rc.settings(file = TRUE) to my .Rprofile file, thanks 
to Deepayan Sarkar).

Now, however when I type a part of a command or a path and hit <TAB>, I 
get 'Wrong type argument: stringp, nil'. Trying to use the 'old school' 
method of M-<TAB> is even worse, as I get things prepended rather than 
completed (e.g., Swea M-<TAB> gives me  c:/Documents and Settings/Jim/My 
Documents/Analyses/Kaufman/Rutkowski/First set 6-9-08/Swea).

I don't think I have made any fundamental changes to my Emacs/ESS setup 
other than updating when new versions come out. Anyway, I have tried 
Vincent Goulet's modified Emacs as well as the 'regular' win32 binary 
from GNU Emacs (GNU Emacs 22.2.1 (i386-mingw-nt5.1.2600) and I get the 
same result. I run ESS from an updated svn source (updated today), so 
that should be > 5.3.7.

Perusing the ESS sources I see ess-R-complete-object-name which I tried 
to activate using

(define-key inferior-ess-mode-map "\t" 'ess-R-complete-object-name)

in my .emacs file, however no joy.

I assume I am missing something obvious, but it escapes me. Any suggestions?



James W. MacDonald, M.S.
Affymetrix and cDNA Microarray Core
University of Michigan Cancer Center
1500 E. Medical Center Drive
7410 CCGC
Ann Arbor MI 48109

More information about the ESS-help mailing list