[ESS] ess-mode 5.3.7; R 2.7.0; help is not creating a help buffer

Marcus, Jeffrey Jeffrey.Marcus at nuance.com
Mon Apr 28 19:03:44 CEST 2008

I just upgraded from Version R-2.4.1 to R-2.7.0 on Windows XP.  When I invoked the new version of R from Emacs 22.2.1 (using Vincent Goulet's Emacs
distribution) and tried getting help on the R matrix function, a buffer was
created with the usual name *help[R](matrix}* was created but it was
empty. This is true for all functions I tried whether i used help() or
? and it was true for Ess 5.3.5, 5.3.6, and 5.3.7.  

In case it means anything, help(chmhelp=T) will give me CHM help and help(chmhelp=F) will print the help contents in the R buffer itself. 

I filed a bug report to ess-bugs on April 24 but haven't heard anything so was wondering if anybody had seen this and had advice on how to fix it. Thanks. 


Manager, Applied Data Analysis

One Wayside Road
Burlington  MA  01803

781 565 5000   Office
781-565 5001   Fax

The experience speaks for itself (tm) 

More information about the ESS-help mailing list