[ESS] R: ess problems on xemacs 21.4.19 on AIX

CECCHI FABIO fabio.cecchi at bancaditalia.it
Fri Mar 3 12:11:05 CET 2006

Hi Stephen,
	with respect the "voidness" of ess-s-versions-create, following your suggestion I solved the problem.
So many thanks! Below I describe what I have done.
Now I can use xemacs 2.4.19 with tarballs xemacs-sumo-2005-03-07.tar.bz2 and xemacs-mule-2005-03-07.tar.bz2 and ess-5.2.12.

I also tried to use the last tarballs (xemacs-sumo-2005-12-08.tar.bz2 tarball and xemacs-mule-2005-12-08.tar.bz2) of xemacs with such trick but the problem  related to error:
	Symbol's value as variable is void: inferior-ess-font-lock-keywords

Many thanks,
Using the command "M-x locate-library RET essd-sp6" I saw that essd is located in the old tree (i.e. of ess-5.2.3) as you suspected. This installation is under the 'canonical' place of xemacs (i.e. xemacs-packages/etc/ess, xemacs-packages/lisp/ess, xemacs-packages/man/ess and xemacs-packages/info/ess.info).
In order to follow your suggestion I deleted this directories. The ess-5.2.12 tree is located under xemacs-packages with the same name (ess-5.2.12) and in the site-start.el I put
(load "/opt/freeware/lib/xemacs/xemacs-packages/ess-5.2.11/lisp/ess/ess-site")
 where the "/opt/freeware" is the root of installed packages with rpm system on AIX.

For what I can understand now xemacs loads ess-site from "/opt/freeware/lib/xemacs/xemacs-packages/ess-5.2.11/lisp/ess" since it shows this pathname in the minibuffer during the loading, and the problem disappear. 


-----Messaggio originale-----
Da: Stephen Eglen [mailto:S.J.Eglen at damtp.cam.ac.uk] 
Inviato: giovedì 2 marzo 2006 19.22
Cc: ess-help at stat.math.ethz.ch
Oggetto: [ESS] ess problems on xemacs 21.4.19 on AIX

Dear Fabio,
did you resolve this problem?

 > Also installing earlier versions of ess the problem still remains.
 > Then I have installed xemacs-21.4.19 with previous version of tarballs
 > (xemacs-sumo-2005-03-07.tar.bz2 tarball and
 > xemacs-mule-2005-03-07.tar.bz2).
 > ess-5.2.3 is present in the xemacs tarball, and stata or SAS process run
 > correctly.

 > At this point,  I installed ess-5.2.12 but when I start xemacs I get the
 > following error:
 >              Symbol's function definition is void:
 >              ess-s-versions-create

After getting the error, what does the following return?

  M-x locate-library RET essd-sp6

How did you install ess-5.2.12?  My guess is that if you have
ess-5.2.3 still hanging around, ESS may be finding the version of
essd-sp6.el (where ess-s-versions-create is defined, but probably not
in version 5.2.3) from the 5.2.3 directory tree.  Try moving the 5.2.3
out of the way, and swapping in the 5.2.12 tree.


** Le e-mail provenienti dalla Banca d'Italia sono trasmesse in buona fede e
non comportano alcun vincolo ne' creano obblighi per la Banca stessa,
salvo che cio' non sia espressamente previsto da un accordo scritto.
Questa e-mail e' confidenziale. Qualora l'avesse ricevuta per errore, La
preghiamo di comunicarne via e-mail la ricezione al mittente e di
distruggerne il contenuto. La informiamo inoltre che l'utilizzo non
autorizzato del messaggio o dei suoi allegati potrebbe costituire reato.
Grazie per la collaborazione. 
-- E-mails from the Bank of Italy are sent in good faith but they are neither
binding on the Bank nor to be understood as creating any obligation on its
part except where provided for in a written agreement. This e-mail is
confidential. If you have received it by mistake, please inform the sender
by reply e-mail and delete it from your system. Please also note that the
unauthorized disclosure or use of the message or any attachments could be
an offence. Thank you for your cooperation. **

More information about the ESS-help mailing list