[ESS] xargs XEmacs bug squashed

Detlef Steuer detlef.steuer at hsu-hamburg.de
Wed Jan 11 15:07:43 CET 2006


I found the following in the net and it worked:

Vin Shelton
	Dec 27 2005, 11:53 am   show options
Newsgroups: comp.emacs.xemacs
From: Vin Shelton <a... at xemacs.org> - Find messages by this author
Date: Tue, 27 Dec 2005 11:53:45 -0500
Local: Tues, Dec 27 2005 11:53 am
Subject: Re: xemacs and ESS after update
Reply | Reply to Author | Forward | Print | Individual Message | Show original | Report Abuse

- Hide quoted text -
- Show quoted text -
"Klaus" <kj_n... at gmx.net> writes:
> I don't think, it is a bug in ecb. Probably it's related to some
> underlying piece of software, that is used both by ecb and ess. Anyway,
> here is the traceback. As you said I generated it by starting xemacs
> -vanilla and the calling M-x ecb activate:

> Debugger entered--Lisp error: (file-error "Searching for program" "No
> such file or directory" "xargs")
>   start-process-internal("*call-process*" nil "xargs")
>   apply(start-process-internal "*call-process*" nil "xargs" nil)
>   call-process-internal("xargs" nil nil nil)
>   apply(call-process-internal "xargs" nil nil nil nil)
>   call-process("xargs")
>   byte-code("..." [grep-null-device call-process "find" nil "-print0" 0
> "xargs" "-0" "-e" gnu] 7)
>   (defvar grep-find-use-xargs (byte-code
> "ÁÂɉÄ&Åk«ÁÆɉÇÈ&Åk«,ɇÁÆ!Åk‡"
> [grep-null-device call-process "find" nil "-print0" 0 "xargs" "-0" "-e"
> gnu] 7)
> ("d:\\Applications\\xemacs-packages\\lisp\\xemacs-base\\compile.elc" .
> 12251))
>   load-internal("compile" nil t nil binary)
>   load("compile" nil t nil)

>	Klaus -
>Thanks for sending this along.  It looks like if you
>(setq grep-find-use-xargs nil)
>before you load compile.el, this may address the problem.  Does that
>work for you?
>  - Vin

So I put 
(setq grep-find-use-xargs nil)
before (reqiure 'ess-site) in my init.el and it worked.

Don't ask why, I'm from the <ESC>:wq part of the world and use (X)Emacs exclusively for ESS.



>Dear Rodney,
>I tried today to get the current XEmacs for Windows to work with the current
>ESS, with a view towards updating my init file and installation
>instructions. So far, after the following steps (mostly following the
>directions in the ESS manual), I've been unsuccessful:
>(1) I downloaded the Windows installer for version 21.4.18 of XEmacs and did
>a default install.
>(2) I downloaded ess-5.2.11.zip and unzipped it in C:\XEmacs\ess.
>(3) I created an init.el file with the following contents in the
>subdirectory .xemacs under my home directory:
>	(load "C:/XEmacs/ess/ess-5.2.11/lisp/ess-site")
>	(setq inferior-R-program-name "C:/R/R-2.2.1/bin/rterm.exe")
>(4) Starting up Xemacs produced the dreaded "xargs" error (as expected):
>	Searching for program: No such file or directory, xargs
>(5) Using the XEmacs package menu, I updated xemacs-base to the pre-release
>version (since this is supposed to fix the "xargs" error).
>(6) I closed XEmacs and restarted it. This produced the following warning
>(in a *Warnings* buffer):
>	(warning/warning) Autoload error in:
>	Already loaded 
>I messed around a bit after this, but haven't been able to get past this
>error. The auto-autoloads.el file says that it shouldn't be modified. Note
>that these problems are independent of the init.el file that I distribute,
>and which, along with ESS, actually still seems to work.
>As before, I'm willing to update my init file and associated document, but
>I'm stuck at this point and don't have a great deal of time to persist.
> John

More information about the ESS-help mailing list