[ESS] Debugging in R

Kasper Daniel Hansen kaha at biostat.ku.dk
Fri Jun 24 21:41:26 CEST 2005

The debug package is an R package.

I think that what Martin observed is that some ESS functionality hangs. 
Eg. ESS has tab completion for the help function, and that does not work 
in a recover session. But I think that what you are describing is 
something different - that everything hangs? So let me clarify: when I do 
options(error = recover) it works exactly as under the console - but I 
might have problems with some extended ESS functionality.

Your message seems to indicate that it worked recently. I am using 
Emacs under Mac Os Tiger with ESS 52.8 (the newest).

I am not sure I can help further - I am quite mystified if using 
options(error = recover) crashes the Emacs session...


On Fri, 24 Jun 2005, Ross Boylan wrote:

> On Fri, 2005-06-24 at 04:40 +0200, Kasper Daniel Hansen wrote:
> > I do not really follow this. There are two basic ways to do debugging as I 
> > understand it. One is to use the debug package, which I have no expeience 
> > with, and the other is to use the build in R commands.
> The debug package is an R package, an ESS package, or an emacs package?
> I didn't see any reference to it in the ESS info file.
> > 
> > For my case, everything I have tried works fine. And I am positive that 
> > options(error = recover) works fine.
> > 
> > Have you set you editor to something strange? I get
> >   > getOption("editor")
> >   [1] "emacsclient"
> So do I.
> Martin M observed in a different message that the use of
> options(error=recover) hangs some things, but not others.
> This is very odd, since what I experienced was that both the R session
> and emacs were totally frozen--no response to keyboard or mouse, no
> display of the stuff inside the frame.  Killing the R process didn't
> help.  I had to kill my whole emacs session.
> Maybe some configuration info is relevant.
> Running Debian GNU/Linux, basically testing (just a hair beyond the
> recent release).  
> emacs21              21.4a-1 
> r-base-core          2.1.0-1
> kdelibs              4:3.3.2-6.1
> xserver-common       4.3.0.dfsg.1-14
> I do seem to recall having error=recover work OK in ESS fairly
> recently..
> ______________________________________________
> ESS-help at stat.math.ethz.ch mailing list
> https://stat.ethz.ch/mailman/listinfo/ess-help

More information about the ESS-help mailing list