[ESS] TAGS only the first function in some files

Tim Hesterberg timh at insightful.com
Thu Dec 2 18:41:43 CET 2004

>Received-SPF: none (hypatia: domain of ess-help-bounces at stat.math.ethz.ch does not designate permitted sender hosts)
>Received-SPF: none (hypatia: domain of sje30 at damtp.cam.ac.uk does not
>	designate permitted sender hosts)
> > I tried to use etags to tag my R files.
> > 
> > For some files it indexes all functions but for some files it only finds 
> > the first function defined and skips the rest???
> > 
> > I ran 'etags *.R' in the folder containing my scripts, did I miss 
> > something vital?
>Dear Hendrik,
>When I do etags --help I get a list of languages, but none of which
>seem to be for R, or recognise .R suffix.  
>$ etags -V
>etags (standalone 21.3.50)
>It seems to work for functions in some files, but not others.  Can you
>let us know how your etags finds functions - this is something we
>could add to the manual.   (Or are you also passing a -r REGEXP
>If you can provide a reproducible example, we can get looking into
>this a bit deeper, thanks!

For what it is worth, I do this:

foreach d (resample)
	/usr/bin/etags -a -o funsTAGS --regex=@updateTAGSregexp $d/funs/*.q $d/funs/*.qpp

where updateTAGSregexp is this file:

/This is a file of regular expressions to be used by updateTAGS/
/First normal names, no subscripting or assignment form/
/Use grouping to get just the name/
/"*\([.A-Za-z][.A-Za-z0-9]*\)"*[ \t]*\(<-\|_\)/\1/
/Now the subscripting versions, must be quoted/

More information about the ESS-help mailing list