R not running inside emacs any longer

Douglas Bates bates at stat.wisc.edu
Sun Sep 9 19:49:37 CEST 2001

Faheem Mitha <faheem at email.unc.edu> writes:

> Dear People,
> I'm running Debian (2.2r3) with 
> ||/ Name           Version        Description
> +++-==============-==============-============================================
> ii  ess            5.1.18-0       Emacs statistics mode, supporting R,S  
> ii  r-base         1.3.1-1        `GNU S' - A language and environment for
> ii  emacs21        21.0-0.1       The GNU Emacs editor.
> ii  emacs20        20.7-2         The GNU Emacs editor.
> ii  xemacs21       21.1.10-5      Editor and kitchen sink
> The ESS and R binaries are by Douglas Bates.
> It is extremely puzzling, but R/ESS was working just fine with GNU Emacs
> 20.7 and after I posted to this list back in late July, GNU Emacs 21
> prerelease was working just fine too.
> However, when I checked it recently, R would not run any longer on either
> of these GNU Emacs versions. When I try to run R I get "selecting deleted
> buffer". I recognise this error message from when I have deleted the ess
> buffer accidentally, and sure enough there does not seem to be an ess
> buffer on startup.
> However, R works fine with xemacs and also on the console. Go figure. Does
> anyone have any idea what I might have screwed up?

The archive at http://cran.us.r-project.org/bin/linux/debian now has
ess_5.1.19-0_all.deb in it.  Try upgrading to that.

(I have asked the Debian maintainer of the ess package to create and
 upload ess_5.1.19-1_all.deb to the Debian archives but have not heard
 back from him yet.  I created the version on the cran archive but I
 don't want to do a non-maintainer upload to Debian until Camm has a
 chance to look at this version.)
ess-help mailing list -- To (un)subscribe, send
subscribe	or	unsubscribe
(in the "body", not the subject !)  To: ess-help-request at stat.math.ethz.ch

More information about the ESS-help mailing list