object completion list

Vadim Ogranovich vograno at arbitrade.com
Tue Apr 24 22:23:55 CEST 2001

Hi, I am in the process of installing/starting using ESS-5.1.18 on Sun
Solaris, Emacs 20.4.1. Currently I have a problem with object name
completion in Splus5. Here are the symptoms:
* if I ran ESS via ESC-x S+3 and then try to complete 'lib' (expecting to
get 'library') than completion works fine, but the interface to the help
system (ess-display-help-on-object) breaks with the following message:
cat: illegal option -- d
usage: cat [ -usvtebn ] [-|file] ...
* if I ran ESS via ESC-x S+5 then completion doesn't work (I guess that the
completion list is simply empty), but ess-display-help-on-object works just

Any suggestion?

Thanks, Vadim

P.S. I feel that somehow this might be related to another problem I had.
Here I include the description of that problem which I posted a couple of
hours ago.

Hi, I am in the process of installing ESS-5.1.18. One problem that I have is
to change the default S program name from S+3 to S+5. I edited ess-site.el
and uncommented there the following line

(setq-default inferior-S-program-name inferior-S+5-program-name)

Still ESC-x S defaults to S+3 rather than to S+5. I checked the value of
inferior-S-program-name and it was Splus5 which is what I wanted.

I should tell that ESC-x S+3 runs the correct Splus5, but I am not sure how
it manages to do this.

Any help will be appreciated.

ess-help mailing list -- To (un)subscribe, send
subscribe	or	unsubscribe
(in the "body", not the subject !)  To: ess-help-request at stat.math.ethz.ch

More information about the ESS-help mailing list