ESS source directory and filenames

Brett Presnell presnell at
Mon Jan 3 23:31:47 CET 2000

Dear All,

I think I've been here before when I tried once upon a time to use
ESS, but still the answer escapes me.

I'm trying to use ESS-5.1.11 with GNU Emacs 20.4.1 running under
Solaris 2.6 (SunOS 5.6) on an Ultra 10.  I'm also running S version
5.0 (release 3) and R version 0.90.1, though I don't think these have
anything to do with my ESS problems.

What I would like is to have dump files saved in directories/files of
the form

     "working S directory"/S-src/myfcn.S


     "working R directory"/R-src/myfcn.R

In my .emacs I have

(setq ess-source-directory
	  (lambda () (file-name-as-directory
		       (concat (car ess-search-list)

(setq ess-dump-filename-template "%s.S")

Of course I've tried many variations, particularly of the setting of
ess-dump-filename-template, since I know that something better than
this will be required to get what I want.  In particular I've tried
working with ess-suffix and adding the setting of
ess-dump-filename-template to inferior-ess-mode-hook.  Also, with
regard to the setting of ess-source-directory, I find that
ess-directory is nil in my S and R process buffers, which is why I'm
using ess-search-list above.

Here are the problems I'm having:

1.  In S, using C-cC-d results in the listings of the searches being
    echoed in the S (or R) process buffer.  This is very annoying.
    Can it be turned off?

2.  When running S, file-name-as-directory seems to get work
    correctly, but my setting of ess-dump-filename-template is ignored
    or overridden by the default.  Thus if I start S in my home
    directory and try to create myfcn with C-cC-d, the files gets
    dumped to "~/S-src/presnell.myfcn.S".

    I've tried adding the change of ess-dump-filename-template to
    inferior-ess-mode-hook to no avail.  Neither will Emacs let me use
    "customize" to modify the variable, though I notice that in
    essd-sp5.el it is defined as part of S+5-customize-alist. (BTW,
    the defvar of S+5-customize-alist is duplicated in my copy of
    essd-sp5.el.)  I've tried other things too, but I think the basic
    problem is that my setting of ess-dump-filename-template is
    ignored or overwritten.

3.  When running R, even file-name-as-directory doesn't work properly
    because ess-search-list's value is

    (".GlobalEnv" "Autoloads" "package:base")

    so ESS tries to dump to /usr/users/presnell/.GlobalEnv/R-src/
    Of course ess-dump-filename-template's value is "presnell.%s.R"
    which isn't really what I want either.

Any help will be much appreciated.  In fact, if anyone is doing
something similar, just sending along the relevant lines from your
.emacs would be great.

Thanks in advance.

Brett Presnell
Department of Statistics
University of Florida
(presnell at
ess-help mailing list -- To (un)subscribe, send
subscribe	or	unsubscribe
(in the "body", not the subject !)  To: ess-help-request at

More information about the ESS-help mailing list