Does ess (>= 5.3.10) now require R ?

Stephen Eglen S.J.Eglen at
Wed Dec 3 19:35:35 CET 2008

Dirk Eddelbuettel <edd at> wrote:

> understand at all; see
> Now someone dug a bit more and it appears that this is due to the test in 
> ess-find-newest-R from essd-r.el --- but I am not enough of an elisper to see
> if that is or is not fault-tolerant to R being present.

I wrote that code, so can check whether it is fault-tolerant to no R.
If it is not fault-tolerant, it should be, and so I will try and fix it
- but won't be able to look at this for a day or two.

> Now, I can easily make Debian's ess depend on Debian's R -- should I ?
No -- I think as ESS edits other types of file, I don't think r-base
should be a prerequisite.  


More information about the ESS-Debian mailing list