[BioC] Error installing development version of DESeq2

Steve Lianoglou lianoglou.steve at gene.com
Fri Jan 17 23:37:36 CET 2014

Hi Kristina,

On Fri, Jan 17, 2014 at 2:29 PM, Kristina M Fontanez <fontanez at mit.edu> wrote:
> Hi Steve-
> Unfortunately, your e-mail came about 10 minutes too late for me. I did indeed destroy my old version (3.0) of R. I did use the R-devel*.pkg available at att.com<http://att.com> but I must have missed the installer prompt that prevented it from killing my current release install.
> Do you have any advice for how I can fix this? I tried to restore my release version of R from a Time Machine backup but I still get the message “R cannot be opened because of a problem”.

Ack -- so .. "[Un]suffered Consequences" ... sorry to hear that.

It's actually been a long time since this has happened to me, so I
forget the exact details of the collateral damage you've just suffered

The good news is that it's not too onerous to recover from scratch.
Just download the latest R-release installer pkg from CRAN. The
installer will (should) contain the same warning telling you what the
command is to perform a "non-destructive" isntall. For what it's
worth, you simply have to open up a terminal and type in the following

sudo pkgutil --forget org.r-project.R.x86_64.fw.pkg

Then continue with the installation and all will be Feng Shui.

After doing so, launching "R" from the terminal should now open
R-3.0.2 (no need to use RSwitch). Just do the usual biocinstall (ie.
source the biocLite script then re-install the packages you need).
Being at MIT, the bandwidth available to you should make this a quick
process, especially since the packages for the mac do not need to be
compiled for installation.

The good news is that after you've done that, you'll have a "working"
multi-R environment you can jump back and forth between by simply
using RSwitch.


Steve Lianoglou
Computational Biologist

More information about the Bioconductor mailing list