[BioC] Using easyRNASeq package: question about BAM/BAI and links to them

Nicolas Delhomme nicolas.delhomme at umu.se
Tue Nov 26 17:13:14 CET 2013

Bonsoir Sylvain,

I have never encountered that situation. I’ve tried to reproduce it but to no avail. Can you:

1) report your sessionInfo() to make sure you are using R-3.0.2 and easyRNASeq-1.8.2?

2) give me a glance of your symlink structure to see if my mockup recapitulated your case?

3) can you try to reproduce the following:

Here is what I did to test easyRNASeq on what I guess was your symlink structure:

a) first I created symlinks in my Desktop/tmp dir:

lrwxr-xr-x  1 delhomme  staff  71 Nov 26 17:02 ACACTG.bam -> /Users/delhomme/Library/R/3.0/library/RnaSeqTutorial/extdata/ACACTG.bam
lrwxr-xr-x  1 delhomme  staff  75 Nov 26 17:02 ACACTG.bam.bai -> /Users/delhomme/Library/R/3.0/library/RnaSeqTutorial/extdata/ACACTG.bam.bai
lrwxr-xr-x  1 delhomme  staff  71 Nov 26 17:02 ACTAGC.bam -> /Users/delhomme/Library/R/3.0/library/RnaSeqTutorial/extdata/ACTAGC.bam
lrwxr-xr-x  1 delhomme  staff  75 Nov 26 17:02 ACTAGC.bam.bai -> /Users/delhomme/Library/R/3.0/library/RnaSeqTutorial/extdata/ACTAGC.bam.bai
lrwxr-xr-x  1 delhomme  staff  71 Nov 26 17:02 ATGGCT.bam -> /Users/delhomme/Library/R/3.0/library/RnaSeqTutorial/extdata/ATGGCT.bam
lrwxr-xr-x  1 delhomme  staff  75 Nov 26 17:02 ATGGCT.bam.bai -> /Users/delhomme/Library/R/3.0/library/RnaSeqTutorial/extdata/ATGGCT.bam.bai
lrwxr-xr-x  1 delhomme  staff  71 Nov 26 17:02 TTGCGA.bam -> /Users/delhomme/Library/R/3.0/library/RnaSeqTutorial/extdata/TTGCGA.bam
lrwxr-xr-x  1 delhomme  staff  75 Nov 26 17:02 TTGCGA.bam.bai -> /Users/delhomme/Library/R/3.0/library/RnaSeqTutorial/extdata/TTGCGA.bam.bai

pointing to the example data package (RnaSeqTutorial) companion of easyRNASeq.

b) then in R I ran:

counts <- easyRNASeq(filesDirectory="Desktop/tmp",

and I got the expected count table.

4) btw, how did you create the links? As far as I remember, Windows does not create symlink in the same way a Unix system does, which is what I tried here. 



Nicolas Delhomme

Nathaniel Street Lab
Department of Plant Physiology
Umeå Plant Science Center

Tel: +46 90 786 7989
Email: nicolas.delhomme at plantphys.umu.se
SLU - Umeå universitet
Umeå S-901 87 Sweden

On 26 Nov 2013, at 16:37, Sylvain Foisy Ph. D. <sylvain.foisy at diploide.net> wrote:

> Hi,
> I am trying to use easyRNASeq to create count tables for DESeq analysis. I have about a hundred BAM files with their associated indexes, located in my file system and sorted in folders, on for each provider and in each one folder for each tissue. To not use to much space, I created simlinks from each of these BAM/BAI combo toward a single location so that easyRNASeq can read them all. When I try my command, I get this error:
> Error in easyRNASeq(filesDirectory = "/shares/data2/tmp01/inflammgen_temp_transfer/htseq_datastore/RNASeq_datastore/RNASeq_comprehensive_catalog/4.diff_ex_analysis/4.0.link2files/2013_10_29-16_00_07_NCBI_build37.from.2.2.phred_q_trimming_2013_10_24",  : 
>  Index files (bai) are required. They are missing for the files: blablabla...
> But, the files are there :-( I removed the BAI symlinks and cp the real files to the same location and I get the same mistake... Is my idea of symlinking from the source the problem?
> Any idea appreciated ;-)
> Best regards
> Sylvain
> -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
> Sylvain Foisy, Ph. D.
> Consultant principal | Lead Consultant
> Diploide BioIT -> TI pour la vie / IT for Life
> M: sylvain.foisy at diploide.net
> T: (514) 893-4363
> W: http://www.diploide.net
> -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
> 	[[alternative HTML version deleted]]
> _______________________________________________
> Bioconductor mailing list
> Bioconductor at r-project.org
> https://stat.ethz.ch/mailman/listinfo/bioconductor
> Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor

More information about the Bioconductor mailing list