[BioC] qcplot() error in methylumi?

Oliver Lyttleton o.lyttleton at bristol.ac.uk
Mon Mar 19 15:33:55 CET 2012

Tim Triche, Jr. <tim.triche at ...> writes:

> try qc.probe.plot()

I tried using qc.probe.plot.

I have methylumi version 2.0.13 ( from Bioconductor version 2.9)

I installed ggplot2_0.9.0.

I also had to install the reshape package.

However, when I ran the qc.probe.plot function (e.g. qc.probe.plot(lumi450k,
"NORM_A")), I got the following error:

Error in qc.probe.plot(lumi450kData, controlTypes(lumi450kData)[1]) : 
  could not find function "scale_x_log2"

I looked at the functions available in the ggplot2 package, and I saw that while
there was no "scale_x_log2" function, there was a scale_x_sqrt and a
scale_y_sqrt function. While I accept that log2 and square root aren't
equivalent, I downloaded the sourcecode for the file that contains
qc.probe.plot, changed the function calls for "scale_x_log2" and "scale_y_log2"
to "scale_x_sqrt" and "scale_y_sqrt" respectively.

The qc.probe.plot function now worked. It also worked when I used
"scale_x_log10" and "scale_y_log10".

My question is: what versions of methylumi and ggplot do I need to be using, in
order to get the qc.probe.plot function to work, without modifying the
qc.probe.plot function? Is there a version of ggplot which contains the
scale_x_log2/scale_y_log2 functions?



More information about the Bioconductor mailing list