[BioC] useDevel and update all packages - wrong library location?

Janet Young jayoung at fhcrc.org
Wed Aug 15 20:41:11 CEST 2012

Hi there,

Until now I haven't used the devel versions of bioc packages at all, but after looking at the instructions at http://www.bioconductor.org/developers/useDevel/  I've started to do that (I want to maintain parallel release and devel installations).

Installing individual packages with biocLite e.g. 
worked OK - it put the new packages in the right location. It worked well a couple of times in a row.  

However, after biocLite gets done installing an individual package, it looks for other out-of-date packages and asks whether I want to update all, some or none. I reply "all" and it then installs devel versions of the packages in the wrong place - in my release version library dir rather than the devel version library dir.

My Rdevel is aliased to "setenv R_LIBS_USER /home/jayoung/traskdata/lib_linux_gizmo/Rdevel ; R"

and from my Rdevel session, here are a couple of possibly useful outputs:
[1] "/home/btrask/traskdata/lib_linux_gizmo/Rdevel"   
[2] "/home/btrask/traskdata/lib_linux_gizmo/R/library"

[1] "/home/btrask/traskdata/lib_linux_gizmo/R/library"

Is .Library what's used as the destination dir - shouldn't it be the same as .libPaths()[1] ?

I wonder if I've misunderstood something here - any tips?

thanks very much,



Dr. Janet Young 

Tapscott and Malik labs

Fred Hutchinson Cancer Research Center
1100 Fairview Avenue N., C3-168, 
P.O. Box 19024, Seattle, WA 98109-1024, USA.

tel: (206) 667 1471 fax: (206) 667 6524
email: jayoung  ...at...  fhcrc.org


More information about the Bioconductor mailing list