[BioC] imageplot error message

Ina Hoeschele inah at vbi.vt.edu
Wed Mar 2 21:51:12 CET 2011

Hi Mark, Mike et al.,
  when doing imageplots for the beadlevel data, I get the following error message (same thing happens when I specify squareSize). Any suggestion why this happens? Thanks ...


Error in res[rowIdx, ] <- resList[[i]][j, ] : 
  number of items to replace is not a multiple of replacement length

> sessionInfo()
R version 2.12.1 (2010-12-16)
Platform: i386-pc-mingw32/i386 (32-bit)

[1] LC_COLLATE=English_United States.1252 
[2] LC_CTYPE=English_United States.1252   
[3] LC_MONETARY=English_United States.1252
[4] LC_NUMERIC=C                          
[5] LC_TIME=English_United States.1252    

attached base packages:
[1] grid      stats     graphics  grDevices utils     datasets  methods  
[8] base     

other attached packages:
 [1] geneplotter_1.28.0   lattice_0.19-13      annotate_1.28.0     
 [4] AnnotationDbi_1.12.0 RColorBrewer_1.0-2   gplots_2.8.0        
 [7] caTools_1.11         bitops_1.0-4.1       gdata_2.8.1         
[10] gtools_2.6.2         beadarray_2.0.4      Biobase_2.10.0      

loaded via a namespace (and not attached):
[1] BeadDataPackR_1.2.1 DBI_0.2-5           limma_3.6.9        
[4] RSQLite_0.9-4       tools_2.12.1        xtable_1.5-6       

----- Original Message -----
From: "Ina Hoeschele" <inah at vbi.vt.edu>
To: "Mark Dunning" <mark.dunning at gmail.com>
Cc: bioconductor at stat.math.ethz.ch
Sent: Friday, February 25, 2011 5:03:51 PM
Subject: Re: expressionQCPipeline

Hi Mark,
  thanks much for all your emails. Sorry for bothering you with this really silly problem once more.

Regarding your expressionQCPipeline problem; it should be trying to
write plots to a directory called "QC.Dir[iChip]". If you run


what does it return?

it created a directory within the current working directory with the name QC.Dir[iChip].
So then I deleted this directory, closed R, and then rerun this code:


nChips <- 8
Chip.Dir <- c("C:/5655508006","C:/5655508014","C:/5655508045","C:/5655508059","C:/5655735016","C:/5655735017","C:/5655735018","C:/5655735079")

iChip <- 1

BLData = readIllumina(useImages=FALSE, illuminaAnnotation="Humanv4")


Then it still gives me the message that the plots already exist! It created a sub-directory QC within the C:/5655508006 directory, as it is supposed to. 
The box-plots look fine, and there are several excel files containing information (detectionMetrics, outlierMetrics etc.). But the plots contained in hyb, 
imageplot, outliers and poscont are all empty.

More information about the Bioconductor mailing list