[BioC] getBM returns error

Freudenberg, Johannes (NIH/NIEHS) [E] johannes.freudenberg at nih.gov
Wed Aug 10 17:23:53 CEST 2011

Hi Wasco,

I have tried your example just now and it worked fine.  But I'm running more current versions of R and Bioconductor.  Have you tried updating R/Bioconductor?

> library("biomaRt")
> mart = useMart("ensembl", dataset = "hsapiens_gene_ensembl") 
> mart
Object of class 'Mart':
 Using the ensembl BioMart database
 Using the hsapiens_gene_ensembl dataset
> o=getBM(c("ensembl_gene_id", "ensembl_transcript_id", "illumina_humanwg_6_v2"), mart=mart)
> head(o)
  ensembl_gene_id ensembl_transcript_id illumina_humanwg_6_v2
1 ENSG00000203347       ENST00000366172                      
2 ENSG00000256017       ENST00000379355          ILMN_1676712
3 ENSG00000236057       ENST00000537266                      
4 ENSG00000236057       ENST00000446137                      
5 ENSG00000245602       ENST00000500835                      
6 ENSG00000247217       ENST00000499475                      
> sessionInfo()
R version 2.13.0 (2011-04-13)
Platform: x86_64-pc-linux-gnu (64-bit)

 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C              
 [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8    
 [5] LC_MONETARY=C              LC_MESSAGES=en_US.UTF-8   
 [7] LC_PAPER=en_US.UTF-8       LC_NAME=C                 
 [9] LC_ADDRESS=C               LC_TELEPHONE=C            

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

other attached packages:
[1] biomaRt_2.8.1

loaded via a namespace (and not attached):
[1] RCurl_1.5-0  tools_2.13.0 XML_3.2-0   


-----Original Message-----
From: Wasco Wruck [mailto:wasco.wruck at charite.de] 
Sent: Wednesday, August 10, 2011 8:17 AM
To: bioconductor at r-project.org
Subject: [BioC] getBM returns error


I am getting an error for a biomaRt getBM() call which used to work before. Has something changed in getBM() or the corresponding web services - or might there be firewall problems? I have the environment variable http_proxy set and other commands through the firewall, e.g. 
package installations work. Also getting the same information from biomart via wget and a xml query works through http_proxy. Here is the

 > library("biomaRt")
 > mart = useMart("ensembl", dataset = "hsapiens_gene_ensembl") Checking attributes ... ok Checking filters ... ok  > o=getBM(c("ensembl_gene_id", "ensembl_transcript_id", "illumina_humanwg_6_v2"), mart=mart)
1 <!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" 
"http://www.w3.org/TR/html4/strict.dtd"> <html><head> <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<title>FEHLER: Die angeforderte URL konnte nicht gefunden werden</title> 
<style type="text/css"><!--   /*
Stylesheet for Squid Error pages
Adapted from design by Free CSS Templates
Released for free under a Creative Commons Attribution 2.5 License
Fehler in getBM(c("ensembl_gene_id", "ensembl_transcript_id", "illumina_humanwg_6_v2"),  :
   The query to the BioMart webservice returned an invalid result: the number of columns in the result table does not equal the number of attributes in the query. Please report this to the mailing list.

 > sessionInfo()
R version 2.11.0 (2010-04-22)

  [1] LC_CTYPE=de_DE.UTF-8       LC_NUMERIC=C
  [3] LC_TIME=de_DE.UTF-8        LC_COLLATE=de_DE.UTF-8
  [5] LC_MONETARY=C              LC_MESSAGES=de_DE.UTF-8
  [7] LC_PAPER=de_DE.UTF-8       LC_NAME=C
  [9] LC_ADDRESS=C               LC_TELEPHONE=C

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base

other attached packages:
[1] biomaRt_2.4.0

loaded via a namespace (and not attached):
[1] RCurl_1.4-1 XML_2.8-1

Best regards,


Wasco Wruck
Institute of Pathology
Charite Campus Mitte
Charite - Universitaetsmedizin Berlin
Chariteplatz 1
10117 Berlin
+49 30 450 536237
wasco.wruck at charite.de

Bioconductor mailing list
Bioconductor at r-project.org
Search the archives: http://news.gmane.org/gmane.science.biology.informatics.conductor

More information about the Bioconductor mailing list